Bug 375881 - Pulseaudio: too many connections
Pulseaudio: too many connections
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
8
i686 Linux
low Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-11 07:44 EST by Brian Cottingham
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-11 11:19:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Cottingham 2007-11-11 07:44:11 EST
Description of problem: 
This morning, when I tried to play some music, the tracks zipped by with no 
real playtime in Amarok. The same thing happened with the Soundcard Detection 
program. /var/log/messages has this:

====
Nov 11 07:09:20 localhost pulseaudio[2712]: sink-input.c: Failed to create sink 
input: too many inputs per sink.
Nov 11 07:09:21 localhost pulseaudio[2712]:last message repeated 30 times
Nov 11 07:09:21 localhost pulseaudio[2712]: protocol-native.c: Warning! Too 
many connections (64), dropping incoming connection.
Nov 11 07:10:21 localhost pulseaudio[2712]:last message repeated 832 times
Nov 11 07:10:21 localhost pulseaudio[2712]: sink-input.c: Failed to create sink 
input: too many inputs per sink.
Nov 11 07:11:38 localhost pulseaudio[2712]: sink-input.c: Failed to create sink 
input: too many inputs per sink.
Nov 11 07:11:48 localhost pulseaudio[2712]: protocol-native.c: Warning! Too 
many connections (64), dropping incoming connection.
====

I'm playing FLAC files, so it's not a binary codec issue, and a reboot didn't 
fix the problem. 

How reproducible: Unknown, persistent thus far.
Comment 1 Brian Cottingham 2007-11-11 09:11:21 EST
When I closed Firefox, my sound came back; it looks like something in Firefox 
was holding the sound system hostage. Flash, perhaps?

I've had the sound problem on the live CD too, but without flash/firefox 
running, so that can't be the only cause. 
Comment 2 Lennart Poettering 2007-11-11 11:19:43 EST
Flash is horrendously broken. It keeps opening devices until it hits EBUSY,
which will take a while on PA.

To make Flash work with PA, install libflashsupport.

Note You need to log in before you can comment on or make changes to this bug.