Bug 37617 - problems with 3c905c-tx driver in rh7.1?
problems with 3c905c-tx driver in rh7.1?
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: distribution (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-25 10:32 EDT by Need Real Name
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-04 19:36:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-04-25 10:32:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)


i have 2 pc's on a lan.  as far as i can tell, everything is set up
correctly (it always worked before i installed rh 7.1).  the problem is 
that the machines cant talk to eachother.  i get a "destination 
unreachable" message from linux, and a "request timed out" message from 
win2k.  however, they can ping themselves, so i know tcp/ip works, and the 
nics arent broken or anything.  the other thing is that whenever a network 
connection times out, i get a weird "diagnostics" mesage that just repeats 
forever every 5 seconds or so.

Reproducible: Always
Steps to Reproduce:
1. just ping whatever.com and let it time out (actually, the only way i 
was ever able to get a reply was by pinging the local machine).

Actual Results:  eth0: transmit timed out, tx_status 00 status e000.
  diagnostics: net 0cfa media 8880 dma 000000a0.
  Flags; bus-master 1, dirty 0(0) current 16(0)
  Transmit list 1e71e200 vs. de71e200.
  0: @de71e200  length 8000002a status 0000002a
  1: @de71e240  length 8000002a status 0000002a
  2: @de71e280  length 8000002a status 0000002a
  3: @de71e2c0  length 8000002a status 0000002a
  4: @de71e300  length 8000002a status 0000002a
  5: @de71e340  length 8000002a status 0000002a
  6: @de71e380  length 8000002a status 0000002a
  7: @de71e3c0  length 8000002a status 0000002a
  8: @de71e400  length 8000002a status 0000002a
  9: @de71e440  length 8000002a status 0000002a
  10: @de71e480  length 8000002a status 0000002a
  11: @de71e4c0  length 8000002a status 0000002a
  12: @de71e500  length 8000002a status 0000002a
  13: @de71e540  length 8000002a status 0000002a
  14: @de71e580  length 8000002a status 0000002a
  15: @de71e5c0  length 8000002a status 0000002a
eth0: transmit timed out, tx_status 00 status e000.
  diagnostics: net 0cfa media 8880 dma 000000a0.
  Flags; bus-master 1, dirty 0(0) current 16(0)
  Transmit list 1e71e200 vs. de71e200.
  0: @de71e200  length 8000002a status 0000002a
  1: @de71e240  length 8000002a status 0000002a
  2: @de71e280  length 8000002a status 0000002a
  3: @de71e2c0  length 8000002a status 0000002a
  4: @de71e300  length 8000002a status 0000002a
  5: @de71e340  length 8000002a status 0000002a
  6: @de71e380  length 8000002a status 0000002a
  7: @de71e3c0  length 8000002a status 0000002a
  8: @de71e400  length 8000002a status 0000002a
  9: @de71e440  length 8000002a status 0000002a
  10: @de71e480  length 8000002a status 0000002a
  11: @de71e4c0  length 8000002a status 0000002a
  12: @de71e500  length 8000002a status 0000002a
  13: @de71e540  length 8000002a status 0000002a
  14: @de71e580  length 8000002a status 0000002a
  15: @de71e5c0  length 8000002a status 0000002a
eth0: transmit timed out, tx_status 00 status e000.
  diagnostics: net 0cfa media 8880 dma 000000a0.
  Flags; bus-master 1, dirty 0(0) current 16(0)
  Transmit list 1e71e200 vs. de71e200.
  0: @de71e200length 8000002a status 0000002a
  1: @de71e240  length 8000002a status 0000002a
  2: @de71e280  length 8000002a status 0000002a
  3: @de71e2c0  length 8000002a status 0000002a
  4: @de71e300  length 8000002a status 0000002a
  5: @de71e340  length 8000002a status 0000002a
  6: @de71e380  length 8000002a status 0000002a
  7: @de71e3c0  length 8000002a status 0000002a
  8: @de71e400  length 8000002a status 0000002a
  9: @de71e440  length 8000002a status 0000002a
  10: @de71e480  length 8000002a status 0000002a
  11: @de71e4c0  length 8000002a status 0000002a
  12: @de71e500  length 8000002a status 0000002a
  13: @de71e540  length 8000002a status 0000002a
  14: @de71e580  length 8000002a status 0000002a
  15: @de71e5c0  length 8000002a status 0000002a

this nic is a 3c905c-tx on eth0.  i did a rh 7.1 "server" installation.
Comment 1 Need Real Name 2001-04-26 11:53:34 EDT
i dont know if this is the kind of comment im supposed to add, but i received 
an email today:

"Hi, I saw you post at RedHat bugzilla. I have the same network card with 
RH7.1. Upto a few months ago there was a specific driver for 3c905-tx and 3c980 
which was called 3c90x. For some reason (that actually I reported) it was 
removed from the distribution and 3c59x driver was engineered to drive it. I 
have been using the 90x driver since then with no problems."

so i guess this problem in rh 7.1 isnt a result of me being dumb afterall.  
*phew* =)
Comment 2 Bogdan Costescu 2001-05-03 07:00:06 EDT
First of all, the 3c90x driver was provided by 3Com and it only supported cards
based on their Cyclone and Tornado chips (905B, 905C/CX, 980). This driver was
intended to work for kernels 2.2 only. It was not distributed with the kernel
source, but it was available from 3Com's site, so some distributions (including
RedHat) added it to their kernels. However, 3Com showed no signs of interest of
porting it to 2.4 kernels, so that's the reason why the 3c90x driver disappeared
from RH 7.1 (actually from 2.4 kernel from RH 7.0 too).
The 3c59x driver supports several generations of 3Com cards, including the ones
supported by 3c90x. This driver is distributed with the kernel source, is
actively maintained and has approximately the same features in 2.2 and 2.4
kernels.

Did you card work with a 3c59x driver before ? If so, from which kernel version
? 3Com released some new cards (905CX, notice the X after C) which had a small
modification, needing more time to reset the Rx part. Because the 3c90x driver
used a very long timeout by default, the cards would function correctly with it,
but not with 3c59x. 3Com didn't provide any documentation about this change, so
we had to modify the 3c59x driver by trial-and-error. The version which works
with these cards is included in kernel 2.2.19 (from pre11 or thereabouts) and in
2.4.3.

Can you post the identification message which is given by the driver when the
network is initialized ? (It should start with version and end with media
setings). Also, if you have any other messages related to eth0 (apart from the
Tx timeouts that you posted), please post them too.
Comment 3 Need Real Name 2001-05-04 19:36:51 EDT
ok guys, sorry about the 'false alarm.'  the problem was an irq conflict 
between my nic and the hpt366 controller on my motherboard.  things seem to be 
working okay now.

Note You need to log in before you can comment on or make changes to this bug.