Bug 376511 - ipw2200 regression in 2.6.23.1-49
ipw2200 regression in 2.6.23.1-49
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i686 Linux
low Severity low
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-11 16:00 EST by Ronald Kuetemeier
Modified: 2008-01-25 11:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-23 11:17:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronald Kuetemeier 2007-11-11 16:00:23 EST
Description of problem:
Wireless hangs with hwcrypto=1 turned on. Worked in 
2.6.23.1-42.  Turned it off and it works ok. 

Version-Release number of selected component (if applicable):
2.6.23.1-49.fc8 SMP mod_unload 686 4KSTACKS
Comment 1 John W. Linville 2008-01-22 15:10:22 EST
Is this still a probelm with current F8 kernels?
Comment 2 Sergio Monteiro Basto 2008-01-23 10:34:39 EST
After upgrade from f7 I had to 
edit /etc/sysconfig/wpa_supplicant and 
comment DRIVERS="-Dwext"
Comment 3 Sergio Monteiro Basto 2008-01-23 11:42:55 EST
(In reply to comment #2)
> After upgrade from f7 I had to 
> edit /etc/sysconfig/wpa_supplicant and 
> comment DRIVERS="-Dwext"

hey! I am not the reporter , just try to help !
Comment 4 John W. Linville 2008-01-23 13:47:47 EST
Ah, thanks for pointing that out. :-)

I'm still going to leave it closed for now -- please reopen if the problem is 
still happending with current F8 kernels.
Comment 5 Ronald Kuetemeier 2008-01-23 16:52:16 EST
Sorry for the late answer.
I just tested with:
vermagic:       2.6.23.9-85.fc8 SMP mod_unload 686 4KSTACKS 
unload module and reload with options ipw2200 led=1 hwcrypto=1 -> works
reboot just in case with the same parm -> works

In other words it works again.  
Comment 6 Ronald Kuetemeier 2008-01-25 11:14:10 EST
Ok some more feedback. 
While it seems to work in general, it's flaky. Meaning I was running a streaming
video and the led went on and off, and the stream began to break up at times.
First thought was I had something CPU intensive running in the back, so I
rebooted since I just upgraded the kernel via yum. Clean fresh machine same
video same problem.
So I unloaded the module and reloaded without hwcrypto=1 and the problem went away.
modinfo:
vermagic:       2.6.23.14-107.fc8 SMP mod_unload 686 4KSTACKS

Options with problem:
#options ipw2200 led=1 hwcrypto=1

Options without any problem:
options ipw2200 led=1

Workaround run without hwcrypto.

Note You need to log in before you can comment on or make changes to this bug.