Bug 37652 - pinegpg-install sets incorrect paths in pine-4.33-6.6x
Summary: pinegpg-install sets incorrect paths in pine-4.33-6.6x
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: pine (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 40669 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-25 17:07 UTC by Rafal Podeszwa
Modified: 2005-10-31 22:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-16 16:50:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rafal Podeszwa 2001-04-25 17:07:46 UTC
pinegpg-install inserts incorrect paths for display-filters and
sending-filters in .pinerc. They are "/bin" and should be "/usr/bin".

Reproducible: Always
Steps to Reproduce:
1.Install updated pine-4.33-6.6x
2.Run pinepgpg-install as a user

	

Actual Results:  In .pinerc

display-filters=_LEADING("-----BEGIN PGP MESSAGE-----")_
/bin/gpg-check,_LEADING("-----BEGIN PGP SIGNED MESSAGE-----")_
/bin/gpg-check

# This defines a program that message text is piped into before MIME
# encoding, prior to sending
sending-filters=/bin/gpg-sign,/bin/gpg-encrypt _RECIPIENTS_
,/bin/gpg-sign+encrypt _RECIPIENTS_ 


Expected Results:  All paths should be /usr/bin

The solution is to change bindir in pinegpg-install

Comment 1 Mike A. Harris 2001-04-26 19:59:49 UTC
Hmm.  Don't know how that happened..  Will fix.

Comment 2 Dan Anderson 2001-05-01 23:23:00 UTC
Same problem in RedHat 7.1 package pine-4.33-8.  Here's the fix (change
bindir=/bin to /usr/bin and change ~/.pinepgp to $HOME/.pinepgp as "~" is not in
the original bourne shell)

--- /usr/bin/pinegpg-install.ori        Fri Mar 16 08:47:57 2001
+++ /usr/bin/pinegpg-install    Tue May  1 16:22:09 2001
@@ -1,7 +1,7 @@
 #!/bin/sh
 
-bindir=/bin
-tmpdir=~/.pinepgp
+bindir=/usr/bin
+tmpdir=$HOME/.pinepgp
 PINERC=$HOME/.pinerc
 
 case $0 in


Comment 3 Mike A. Harris 2001-05-16 16:47:23 UTC
*** Bug 40669 has been marked as a duplicate of this bug. ***

Comment 4 Mike A. Harris 2001-05-16 16:50:28 UTC
Just for the benefit of anyone reading this message, this bug is present
in all of the currently released PINE packages for all releases of Red Hat
Linux.  (5.2/6.2/7.0/7.1)

The bug is fixed internally, and the next release of PINE should have the
fix included.

Thanks

Comment 5 Mike A. Harris 2001-05-28 19:40:38 UTC
Fixed in pine-4.33-9 in Rawhide.


Note You need to log in before you can comment on or make changes to this bug.