Bug 376591 - Compiz not working on i855GM
Compiz not working on i855GM
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-11 16:50 EST by Peter Janakiev
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-12 05:41:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Janakiev 2007-11-11 16:50:13 EST
Description of problem:
After fresh install of Fedora 8 (DVD version) compiz is not starting, stating:
 $ compiz --replace
compiz (core) - Fatal: GLX_EXT_texture_from_pixmap is missing
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0
But actually there is such extension:

$ glxinfo | grep pixmap
    GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, 
    GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap

And AIGLX is loaded:
 $ grep AIGLX /var/log/Xorg.0.log
(==) AIGLX enabled
(WW) AIGLX: 3D driver claims to not support visual 0x23
(WW) AIGLX: 3D driver claims to not support visual 0x24
(WW) AIGLX: 3D driver claims to not support visual 0x25
(WW) AIGLX: 3D driver claims to not support visual 0x26
(WW) AIGLX: 3D driver claims to not support visual 0x27
(WW) AIGLX: 3D driver claims to not support visual 0x28
(WW) AIGLX: 3D driver claims to not support visual 0x29
(WW) AIGLX: 3D driver claims to not support visual 0x2a
(WW) AIGLX: 3D driver claims to not support visual 0x2b
(WW) AIGLX: 3D driver claims to not support visual 0x2c
(WW) AIGLX: 3D driver claims to not support visual 0x2d
(WW) AIGLX: 3D driver claims to not support visual 0x2e
(WW) AIGLX: 3D driver claims to not support visual 0x2f
(WW) AIGLX: 3D driver claims to not support visual 0x30
(WW) AIGLX: 3D driver claims to not support visual 0x31
(WW) AIGLX: 3D driver claims to not support visual 0x32
(II) AIGLX: Loaded and initialized /usr/lib/dri/i915_dri.so


Version-Release number of selected component (if applicable):
compiz --version
compiz 0.6.2
rpm -q compiz
compiz-0.6.2-3.fc8

How reproducible:
Always

Steps to Reproduce:
1. Start desktop effects application
2. Click Enable
3.
  
Actual results:
Trying to start compiz but fails, returns to metacity.

Expected results:
Start compiz

Additional info:
The exact video is 

00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated
Graphics Device (rev 02)
00:02.1 Display controller: Intel Corporation 82852/855GM Integrated Graphics
Device (rev 02)
Comment 1 Peter Janakiev 2007-11-12 05:41:08 EST
Reason found: the user for testing was an old fedora 7 user with all its
settings kept in $HOME. Removing the $HOME/.gconf/apps/compiz dir solves the
issue for me, still a notice for the issue would be nice, as how can a user know
what the issue is while we say: Missing extension. 

Note You need to log in before you can comment on or make changes to this bug.