Bug 37672 - Cannot see/mount Solaris x86 UFS partitions.
Cannot see/mount Solaris x86 UFS partitions.
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
low Severity low
: ---
: ---
Assigned To: Alexander Viro
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-25 15:11 EDT by charles_fisher
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-21 21:27:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description charles_fisher 2001-04-25 15:11:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)


I triple-boot Linux, Solaris 8 x86 6/00, and WinNT.

Normally, Solaris partitions are seen as the system boots:

Partition check:
hda: hda1 hda2 <solaris: [s0] hda5 [s1] hda6 [s2] hda7 [s7] hda8 >
  hda3 hda4 < hda9 hda10 hda11 >

However, under 7.1 (and a new overall system setup - all OSes have been
reinstalled), these partitions are no longer detected. Below is the output
of dmesg under 7.1:

Partition check:
 hda: hda1 hda2 hda3 < hda5 hda6 hda7 > hda4

hda4 is a Solaris partition which should be seen to contain multiple
slices.

hda2 is the Solaris boot partition in msdos format - I can still mount this
and use it to exchange files.

I notice that fs/ufs.o is available as a module. Can I make an initrd with
this module to solve the problem?

p.s. I notice that there is no fs/ntfs.o module. Why did you leave it out?
Comment 1 Arjan van de Ven 2001-04-25 15:32:20 EDT
NTFS is totally unusable, although people are working on improving that.
The solaris partitiontype was indeed not enabled, we'll enable it for
next kernels. UFS reading is fine, appart from an occasional kernel crash. UFS
writing is dangerous and seriously discouraged.
Comment 2 Trevin Beattie 2001-05-21 21:27:33 EDT
Ditto for NetBSD partitions.  With RedHat 7.0:

May 20 14:27:27 clay kernel: SCSI device sda: hdwr sector= 512 bytes. Sectors=
17836668 [8709 MB] [8.7 GB]
May 20 14:27:27 clay kernel:  sda: sda1 sda2 sda3! < sda5 sda6 sda7 sda8 sda9 >
May 20 14:27:27 clay kernel: SCSI device sdb: hdwr sector= 512 bytes. Sectors=
8910423 [4350 MB] [4.4 GB]
May 20 14:27:27 clay kernel:  sdb: sdb1 sdb2! < sdb5 sdb6 sdb7 sdb8 sdb9 >

After upgrading to RedHat 7.1:

May 21 13:27:11 clay kernel: SCSI device sda: 17836668 512-byte hdwr sectors
(9132 MB)
May 21 13:27:11 clay kernel: Partition check:
May 21 13:27:11 clay kernel:  sda: sda1 sda2 sda3
May 21 13:27:11 clay kernel: SCSI device sdb: 8910423 512-byte hdwr sectors
(4562 MB)May 21 13:27:11 clay kernel:  sdb: sdb1 sdb2

I can load the ufs module manually, but this doesn't help since the sda5 etc.
partitions aren't configured ("/dev/sda5 is not a valid block device").
Comment 3 Arjan van de Ven 2001-06-26 09:31:18 EDT
Kernel 2.4.3-12 as released as errata should be able to see the partitions 
and also has a very experimental UFS driver.

Note You need to log in before you can comment on or make changes to this bug.