Bug 376821 - ospfd init script looks for ospf6 configuration and lock file
ospfd init script looks for ospf6 configuration and lock file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: quagga (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Martin Bacovsky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-11 20:56 EST by John Tapparo
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 0.99.9-3.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-20 12:57:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Tapparo 2007-11-11 20:56:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.12) Gecko/20070530 Fedora/1.5.0.12-1.fc5 Firefox/1.5.0.12

Description of problem:
When I try to start the ospfd service, it does not start.

Upon further investigation in the /etc/rc.d/init.d/ospfd script, I notice the following:

LOCK_FILE=/var/lock/subsys/ospf6d
CONF_FILE=/etc/quagga/ospf6d.conf
...
        [ -f $CONF_FILE ] || exit 6



Version-Release number of selected component (if applicable):
quagga-0.99.9-1.fc8.i386.rpm

How reproducible:
Always


Steps to Reproduce:
1.  Update/create the /etc/quagga/ospfd.conf file as needed
2.  Run "service ospfd start"
3.  Note that ospfd is not running.

Actual Results:
ospfd was not running.

Expected Results:
ospfd should be running.

Additional info:
If I change the LOCK_FILE and the CONF_FILE lines as in /etc/rc.d/init.d/ospfd as follows, it starts working.

 LOCK_FILE=/var/lock/subsys/ospfd
 CONF_FILE=/etc/quagga/ospfd.conf

Perhaps they should really be:
 LOCK_FILE=/var/lock/subsys/$cmd
 CONF_FILE=/etc/quagga/$cmd.conf
Just an idle thought.
Comment 1 Fedora Update System 2007-11-14 22:29:38 EST
quagga-0.99.9-3.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update quagga'
Comment 2 John Tapparo 2007-11-17 00:00:51 EST
It looks like this is working to me.  When I rebooted my machine, ospfd started
on its own.

# ls -ld /var/lock/subsys/ospfd
-rw-r--r-- 1 root root 0 Nov 16 23:50 /var/lock/subsys/ospfd
# last reboot | head -1
reboot   system boot  2.6.21-2950.fc8x Fri Nov 16 23:49          (00:07)
# service ospfd status
ospfd (pid 1140) is running...
# rpm -qfV /etc/init.d/ospfd
# rpm -q quagga
quagga-0.99.9-3.fc8

I have installed this and looked specifically at this issue.  I have not done
any other regression testing of quagga.
Comment 3 Fedora Update System 2007-11-20 12:57:38 EST
quagga-0.99.9-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.