Bug 376841 - Usage string in ospf6d init script incorrect
Usage string in ospf6d init script incorrect
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: quagga (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Martin Bacovsky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-11 21:04 EST by John Tapparo
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 0.99.9-3.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-20 12:57:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Tapparo 2007-11-11 21:04:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.12) Gecko/20070530 Fedora/1.5.0.12-1.fc5 Firefox/1.5.0.12

Description of problem:
The usage string in /etc/rc.d/init.d/ospf6d references "$prog" which is not set anywhere in the script:

  *)
        echo $"Usage: $prog {start|stop|restart|reload|condrestart|status}"
        exit 2

It may be useful to note that "PROG" is set in the ospf6d init script.

The /etc/rc.d/init.d/ospfd script uses "$0" rather than "$prog".


Version-Release number of selected component (if applicable):
quagga-0.99.9-1.fc8

How reproducible:
Always


Steps to Reproduce:
1.  Run the ospf6d init script to trigger the usage text.  For example, "/etc/init.d/ospf6d foo"


Actual Results:
The following usage string was displayed:

Usage:  {start|stop|restart|reload|condrestart|status}


Expected Results:
One of the following usage strings should be reported:

Usage: ospf6d {start|stop|restart|reload|condrestart|status}
Usage: /etc/init.d/ospf6d {start|stop|restart|reload|condrestart|status}

Additional info:
The /etc/rc.d/init.d/ospfd script is correct in this regard.

This is probably a "very low" severity, but that wasn't a choice.
Comment 1 Fedora Update System 2007-11-14 22:29:41 EST
quagga-0.99.9-3.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update quagga'
Comment 2 John Tapparo 2007-11-16 23:53:02 EST
Looks like it is fixed to me:

# /etc/init.d/ospfd foo
Usage: /etc/init.d/ospfd {start|stop|restart|reload|condrestart|status}
# rpm -q quagga
quagga-0.99.9-3.fc8

Thank you

I have installed this and looked specifically at this issue.  I have not done a
detailed analysis about how the rest of quagga is working.
Comment 3 Fedora Update System 2007-11-20 12:57:40 EST
quagga-0.99.9-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.