Bug 376871 - TAHI--DHCPv6--Can not get Confirm Message
TAHI--DHCPv6--Can not get Confirm Message
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dhcpv6 (Show other bugs)
5.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: David Cantrell
:
: 377211 (view as bug list)
Depends On:
Blocks: 253764
  Show dependency treegraph
 
Reported: 2007-11-11 21:55 EST by Zhiyong Wu
Modified: 2008-05-21 12:02 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2008-0365
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 12:02:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zhiyong Wu 2007-11-11 21:55:21 EST
Description of problem:

  When having dhcpv6 tests for rfc3315 in the host mode,we found that TN can not 

get Confirm Message in some scenarios.

Version-Release number of selected component (if applicable):

  kernel-2.6.18-43.el5

Software Environment:   
  Testee(NUT):   
    RHEL5 
    Kernel:2.6.18-43.el5 
   
  Tester(TN):   
    FreeBSD6.2
    v6eval-3.0.12.tar.gz
   
TAHI package:    
  DHCPv6_Self_Test_P2_1_0_7.tar.gz

How reproducible:
  every time

Steps to Reproduce:    
  1. Configure TAHI test environment.     
  2. Run the TAHI test suite     
  3. After the test completes, check for the results 
  
Actual results:

   TN can not get Confirm Message. 

Expected results:

   TN can get Confirm Message

Additional info:
  
   please refer to

http://focus.brisbane.redhat.com/~zwu/dhcp_client/20071030/DHCPv6_Self_Test_P2_1_0_7_client/rfc3315/index.html

   (1)3	Part B : Valid Reply message in response to Confirm message

   (2)39	Part A : Confirm message format

   (3)40	Part B : Retransmission of Confirm message

   (4)41	Part C : Maximum Retransmission Time of Confirm message

   (5)42	Part D : Maximum Retransmission Duration of Confirm message

   (6)43	Part E : Reserved Address Information

   (7)71	Part D : Reply message contains NotOnLink in response to a Confirm message

   (8)72	Part E : Reply message in response to a Confirm messag
Comment 1 Zhiyong Wu 2007-11-12 01:01:51 EST
   Also about it:

   when NUT is set to the host mode,and for rfc3646

   pls refer to the url below:

http://focus.brisbane.redhat.com/~zwu/dhcp_client/20071030/DHCPv6_Self_Test_P2_1_0_7_client/rfc3646/index.html

   (1)12	Part A : Rebind message format with Option request Option Format(DNS
Recursive Name Server option)

Comment 2 Zhiyong Wu 2007-11-12 01:11:07 EST
   Also about it:

   when NUT is set to the host mode,and for rfc3646

   pls refer to the url below:

http://focus.brisbane.redhat.com/~zwu/dhcp_client/20071030/DHCPv6_Self_Test_P2_1_0_7_client/rfc3646/index.html

   (1)8	Part A : Confirm message format with Option request Option Format(DNS
Recursive Name Server option)

   (2)9	Part B : Confirm message format with Option request Option Format(Domain
Search List option)

Comment 3 RHEL Product and Program Management 2007-11-15 03:54:47 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Zhiyong Wu 2007-12-28 00:39:58 EST
*** Bug 377211 has been marked as a duplicate of this bug. ***
Comment 5 David Cantrell 2008-01-17 15:22:50 EST
Fixed in dhcpv6-1.0.8, moving to MODIFIED.
Comment 7 Denise Dumas 2008-02-27 10:31:12 EST
In order to debug this problem, we need the test case for RHEL 5.2 with an exact
reproducer, including output with verbose debugging messages from the DHCPV6
software.  One way to do this would be to extract the commands that TAHI runs.
The man pages for dhcp6s, dhcp6r, and dhcp6c all show how to generate verbose
debug messages. 
Comment 9 David Cantrell 2008-03-12 16:16:26 EDT
Fixed in dhcpv6-1.0.10-2.el5.
Comment 13 errata-xmlrpc 2008-05-21 12:02:25 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0365.html

Note You need to log in before you can comment on or make changes to this bug.