Bug 376901 - TAHI--DHCPv6--About RT(Retransmission Time) problem
TAHI--DHCPv6--About RT(Retransmission Time) problem
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dhcpv6 (Show other bugs)
5.0
All Linux
urgent Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks: 253764
  Show dependency treegraph
 
Reported: 2007-11-11 22:18 EST by Zhiyong Wu
Modified: 2009-04-23 09:40 EDT (History)
3 users (show)

See Also:
Fixed In Version: dhcpv6-1.0.10-4.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-02 16:05:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zhiyong Wu 2007-11-11 22:18:07 EST
Description of problem:

  When having dhcpv6 tests for rfc3315 in the host mode,we found that TN can not 

get Confirm Message in some scenarios.

Version-Release number of selected component (if applicable):

  kernel-2.6.18-43.el5

Software Environment:   
  Testee(NUT):   
    RHEL5 
    Kernel:2.6.18-43.el5 
   
  Tester(TN):   
    FreeBSD6.2
    v6eval-3.0.12.tar.gz
   
TAHI package:    
  DHCPv6_Self_Test_P2_1_0_7.tar.gz

How reproducible:
  every time

Steps to Reproduce:    
  1. Configure TAHI test environment.     
  2. Run the TAHI test suite     
  3. After the test completes, check for the results 
  
Actual results:

   TN can not get Confirm Message. 

Expected results:

   TN can get Confirm Message

Additional info:
  
   please refer to

http://focus.brisbane.redhat.com/~zwu/dhcp_client/20071030/DHCPv6_Self_Test_P2_1_0_7_client/rfc3315/index.html

   (1)31	Part C : Retransmission of Solicit Message

   (2)32	Part D : Maximum Retransmission Time of solicit message

   (3)36	Part B : Retransmission of Request messages

   (4)37	Part C : Maximum Retransmission Time of Request messages

   (5)45	Part B : Retransmission of Renew message, T1 and T2 non-zero

   (6)46	Part C : Maximum Retransmission Time of Renew message, T1 and T2 non-zero

   (7)49	Part B : Retransmission of Rebind message, T1 and T2 non-zero

   (8)50	Part C : Maximum Retransmission Time of Rebind message, T1 and T2 non-zero	

   (9)54	Part C : Retransmission of Release message

   (10)59	Part C : Retransmission of Decline message
Comment 1 Zhiyong Wu 2007-11-11 22:28:16 EST
sorry,there are some problems in the bug comments.

it should be modified as shown below:

Actual results:

   RT is not right. 

Expected results:

   RT should be right.
Comment 2 Zhiyong Wu 2007-11-11 22:28:30 EST
sorry,there are some problems in the bug comments.

It should be modified as shown below:

Description of problem:

  When having dhcpv6 tests for rfc3315 in the host mode,we found that RT is not 

right in some scenarios.

Actual results:

   RT is not right. 

Expected results:

   RT should be right.
Comment 3 Zhiyong Wu 2007-11-12 01:26:27 EST
   Also about it:

   when NUT is set to the host mode, and for rfc3736

   pls refer to the url below:

http://focus.brisbane.redhat.com/~zwu/dhcp_client/20071030/DHCPv6_Self_Test_P2_1_0_7_client/rfc3736/index.html

   (1)12	Part B : Retransmission of Information-request message

   (2)13	Part C : Maximum Retransmission Time of Information-request message

Comment 4 RHEL Product and Program Management 2007-11-15 03:54:44 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 Zhiyong Wu 2007-12-28 00:09:55 EST
the bug has been tested PASS with dhcpv6-1.0.4-1.el5.i386.rpm 
dhcpv6-client-1.0.4-1.el5.i386.rpm  libdhcp6client-1.0.4-1.el5.i386.rpm.

Comment 7 Zhiyong Wu 2008-02-25 01:48:36 EST
but the test cases PASS on RHEL5.2 with dhcpv6-1.0.10

for more details, pls refer to

http://focus.brisbane.redhat.com/~zwu/RHEL5.2-Server-20080212.0/20080220/DHCPv6_Self_Test_P2_1_0_8_client_1.0.10/rfc3315/index.html
Comment 12 Yang Ren 2008-05-29 23:49:18 EDT
These bug are fixed.
All are PASS in test report (generated in 2008/05/26 12:57:52)
Comment 13 Lawrence Lim 2008-05-30 00:57:02 EDT
Please include the version number of the package and kernel for all bug update.
Comment 14 Yang Ren 2008-05-30 01:18:45 EDT
kernel : 2.6.18-92.el5
dhcpv6: dhcpv6-client-1.0.10-5.el5.i386.rpm
Comment 15 David Cantrell 2008-06-02 16:05:49 EDT
Marking this as current release because nothing changed in 1.0.10-5.el5 from 1.0.10-4.el5 for this issue.

Note You need to log in before you can comment on or make changes to this bug.