Bug 37694 - resume from suspend doesn't work on Sony Vaio SR7K
resume from suspend doesn't work on Sony Vaio SR7K
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
: 37696 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-25 17:41 EDT by John Heidemann
Modified: 2007-04-18 12:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-16 14:28:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Heidemann 2001-04-25 17:41:48 EDT
this bug is similar to bug 36978, but on different hardware.

With redhat 7.1 installed on a Sony Vaio SR7K laptop,
things run fine and seem to suspend successfully.
On resume, the hard drive spins up and the fan comes on,
but the screen remains blank and the system is non-responsive
to keyboard input.

reproducable: always
to reproduce:
1. boot redhat 7.1
2. press Fn-ESC to suspend the system
  (machine turns off)
3. hit any key to unsusupend
  power light comes on but
  machine is now locked up

The problem persists whether or not you suspend from with X11
or from a virtual terminal.

In Redhat 7.0 suspend/resume worked fine.

The suggestion from <http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=36978>
about rlling back the apmd RPM to that from RH 7.0 did
not solve the problem for me.
Comment 1 Bill Nottingham 2001-04-25 21:19:32 EDT
*** Bug 37696 has been marked as a duplicate of this bug. ***
Comment 2 John Heidemann 2001-04-25 22:07:08 EDT
A possible work-around: I rebuilt redhat's 2.4.2 kernel variant
changing

CONFIG_APM_REAL_MODE_POWER_OFF=y

to

# CONFIG_APM_REAL_MODE_POWER_OFF is not set

This *seems* to allow resume to work, at least from a vritual console
(not from X the one time I tried).

Also, falling back to the 2.2.16 kernel from RH 7.0 allows resume to work
(although breaks other things).  The default 2.2.16 kernel had 
CONFIG_APM_REAL_MODE_POWER_OFF not set.
Comment 3 Arjan van de Ven 2001-04-26 04:39:58 EDT
CONFIG_APM_REAL_MODE_POWER_OFF is a bit different in our kernel.
Even if it is "y", it is still disabled and only enabled if you give the
kernel a commandline option.

The possible culprit is CONFIG_APM_ALLOW_INTS.
Are you in a position to play with that option? We are working on a fix
for this and I'm very interested to know if this fix also works for vaio's.
(basically, we are building a list of machines that require a "y" to the
ALLOW_INTS question and make it automatic for those machines)
Comment 4 Arjan van de Ven 2001-04-26 09:55:20 EDT
Also, do you have an eepro100 ethernet device in the laptop ?
Comment 5 John Heidemann 2001-04-26 13:10:16 EDT
Making realmode boot-time controllable is good (I hope this patch gets 
back to the main tree).  
Maybe the allow-ints stuff can be run-time
controllable as well?  (Building kernels is a pain.)

I'll try building a kernel with ALLOW_INTS (but 2.2.16 worked without that).

I don't have an eepro100, just an old dlink pc-card adaptor.

Comment 6 Arjan van de Ven 2001-04-26 13:14:55 EDT
> Maybe the allow-ints stuff can be run-time
> controllable as well?  (Building kernels is a pain.)
guess what we have in our tree current tree ....

(Oh and it's also submitted to Alan Cox for inclusion in the -ac series and
later the official Linus kernel)

If your vaio works with allow_ints, we can make that the default for it by 
identifying the bios. More about that when it is known _if_ it works.
Comment 7 John Heidemann 2001-05-03 19:58:33 EDT
Follow-up after several days of experimntation:

- with allow-ints off, the default kernel, and the boot option
apm=realmode,debug, and the /etc/sysconfig/apm-scripts/apmscript disabled (1st
line changed to exit 0), able to get power management (supsend/resume) to work
intermittently if I manually change to a text console before suspending.

If I enable apmscript, it always hangs (both with and without the CHANGEVT set).

If I suspend from within X11 it always hangs.

With these constraints it always suspends and resumes at least once and often a
couple of times, but at some point it refuses to resume (as previously described).

- turning on allow-ints makes power management hang on resume always

- As a work-around I rolled back to the RH 7.0 kernel upgrade (2.2.19).  Power
managment now works reliably again from X11.

It seems like something about either the 2.4 kernel (or the patches to it)
breaks APM on my hardware. :-(
Comment 8 liug 2001-05-07 12:04:44 EDT
I am having the similiar problem on my IBM thinkpad T21 with a builtin
eepro100 ethernet card. everything worked fine in redhat 7.0 but with
redhat 7.1, sometimes I couldn't recover from a suspend mode (it doesn't
matter whether I was in console mode, or X11, before the suspend mode.
Some other times, I can recover from suspend mode without a problem.
When I do get the problem, I can see the hard drive started to spin
but I couldn't get the LCD screen back no matter what key I press. 
It looks like the keyboard is not responding. I would guess the system
is still running fine and I could ssh into it if the network interface
weren;t brought down as part of the suspend.
I couldn't really reproduce this problem, but the failure rate is pretty
high, probably around 50%.
Comment 9 Arjan van de Ven 2001-05-07 17:04:44 EDT
The thinkpad problem should be fixed in the latest kernels from rawhide.
Unfortionatly, this is a different problem than the vaio one.
Comment 10 Robert Spier 2002-03-25 02:57:34 EST
I'm seeing a similar problem on my IBM ThinkPad X22 under Skipjack.   After
loading the radeon and agpgart modules and starting X, I can not resume from a
suspend.  It starts - and then hangs in an indeterminiate state with status
lights blinking.  (I'm trying to get IBM to tell me what the lights mean) - but
the trigger is defninitely X related.
Comment 11 Need Real Name 2002-05-16 14:28:45 EDT
I can confirm the problem on the IBM Thinkpad X22 under RH7.3 (both 2.4.18-3 and
2.4.18-4). The hardware is a ATI Radeon Mobility M6 LY and the problem is
related in some way to the use of the radeom and agpgart modules and using X.

If I start X using a configuration that doesn't have 3d accelleration, then the
radeon and agpgart modules are not loaded and there is no trouble with suspend
and resume. It works regardless of whether I suspend while in a VT or in X. Just
"modprobe agpgart; modprobe radeon" doesn't make the system un-suspendable either. 

But if I run X with 3d enabled, then the suspend apparently succeeds, but the
subsequent resume hangs forever with a flashing crescent light on the laptop.
Exiting X before trying to suspend does not help and neither does exiting X AND
"rmmod radeon; rmmod agpgart" The modules unload but the system will still hang
on suspend-and-resume. Weirdly enough, this happens even if I start X up again
after removing the modules without 3d enabled. 

It is as though there is something about starting X in 3d mode on the Radeon
that puts the system in a state from which it does not want to return.
Comment 12 John Heidemann 2002-09-27 20:46:28 EDT
You may close this bug, this problem seems fixed as of RH 7.2.

Note You need to log in before you can comment on or make changes to this bug.