Bug 377001 - Eric won't start. The qt module throws runtime error upon loading.
Eric won't start. The qt module throws runtime error upon loading.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eric (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-11 23:16 EST by Yufei Yuan
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-12 13:51:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yufei Yuan 2007-11-11 23:16:17 EST
Description of problem:

Typing 'eric3' from terminal window gets this error message:

[alex@core2duo ~]$ eric3
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/eric3/eric3.py", line 16, in <module>
    from qt import QTextCodec, SIGNAL, SLOT, qApp
RuntimeError: the sip module supports API v3.0 to v3.4 but the qt module
requires API v3.5

Version-Release number of selected component (if applicable):
[alex@core2duo ~]$ rpm -qi eric
Name        : eric                         Relocations: (not relocatable)
Version     : 3.9.2                             Vendor: Fedora Project
Release     : 3.fc8                         Build Date: Mon 27 Aug 2007 08:35:36
AM CDT
Install Date: Sun 11 Nov 2007 10:21:56 AM CST      Build Host:
hammer2.fedora.redhat.com
Group       : Development/Tools             Source RPM: eric-3.9.2-3.fc8.src.rpm
Size        : 12241207                         License: GPL+
Signature   : DSA/SHA1, Wed 24 Oct 2007 08:43:54 PM CDT, Key ID b44269d04f2a6fd2
Packager    : Fedora Project
URL         : http://www.die-offenbachs.de/detlev/eric3.html
Summary     : Python IDE
Description :
eric3 is a full featured Python IDE.


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Rex Dieter 2007-11-12 07:46:37 EST
I can't reproduce (it worksforme on x86_64 anyway).

More details please,
rpm -q sip PyQt
Comment 2 Yufei Yuan 2007-11-12 13:40:14 EST
[alex@core2duo ~]$ rpm -q sip PyQt
sip-4.6-3.fc8
PyQt-3.17.3-1.fc9
Comment 3 Yufei Yuan 2007-11-12 13:41:14 EST
Just saw that PyQt is for fc9, is that a developmental package?
Comment 4 Rex Dieter 2007-11-12 13:46:55 EST
yes, downgrade back to fc8's stock: PyQt-3.17.1.    Quick-n-dirty method:
rpm -e --nodeps PyQt
yum install PyQt

(And update to PyQt-3.17.3 is in the works, but for now, 3.17.1 is the latest).
Comment 5 Yufei Yuan 2007-11-12 13:48:21 EST
Reversed PyQt to original PyQt-3.17.1-1.fc7 on disk solved the issue. Thanks. It
can be closed.
Comment 6 Rex Dieter 2007-11-12 13:51:38 EST
good news!


Note You need to log in before you can comment on or make changes to this bug.