Bug 377011 - Ogre-samples misconfiguration.
Ogre-samples misconfiguration.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ogre (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-11 23:17 EST by Paul Robinson
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-12 05:23:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paul Robinson 2007-11-11 23:17:03 EST
Description of problem:
The default plugins.cfg file with the ogre-samples page is incorrect, it has the
following two entries:
PluginFolder=/usr/local/lib/OGRE
...
Plugin=Plugin_CgProgramManager.so

Where the PluginFolder should be /usr/lib/OGRE and the
Plugin_CgProgramManager.so file is not included in the default realease and
should be commented out or removed entirely.

This cases the samples to fail during execution.

Version-Release number of selected component (if applicable):
All since Fedora 7

How reproducible:
100%


Steps to Reproduce:
1. ensure the ogre-samples package is installed (yum install ogre-samples)
2. cd /usr/lib/OGRE/Samples
3. ./Crowd

  
Actual results:
[paulr@radon Samples]$ ./Crowd 
Creating resource group General
Creating resource group Internal
Creating resource group Autodetect
SceneManagerFactory for type 'DefaultSceneManager' registered.
Registering ResourceManager for type Material
Registering ResourceManager for type Mesh
Registering ResourceManager for type Skeleton
MovableObjectFactory for type 'ParticleSystem' registered.
OverlayElementFactory for type Panel registered.
OverlayElementFactory for type BorderPanel registered.
OverlayElementFactory for type TextArea registered.
Registering ResourceManager for type Font
ArchiveFactory for archive type FileSystem registered.
ArchiveFactory for archive type Zip registered.
DevIL version: Developer's Image Library (DevIL) 1.6.8pre Aug 22 2007
DevIL image formats: bmp dib cut dcx dds gif hdr ico cur jpg jpe jpeg lif mdl
mng jng pcx pic pix png pbm pgm pnm ppm psd pdd psp pxr sgi bw rgb rgba tga vda
icb vst tif tiff wal xpm raw 
DDS codec registering
Registering ResourceManager for type HighLevelGpuProgram
Registering ResourceManager for type Compositor
MovableObjectFactory for type 'Entity' registered.
MovableObjectFactory for type 'Light' registered.
MovableObjectFactory for type 'BillboardSet' registered.
MovableObjectFactory for type 'ManualObject' registered.
MovableObjectFactory for type 'BillboardChain' registered.
MovableObjectFactory for type 'RibbonTrail' registered.
Loading library /usr/local/lib/OGRE/RenderSystem_GL.so
An exception has occured: OGRE EXCEPTION(7:InternalErrorException): Could not
load dynamic library /usr/local/lib/OGRE/RenderSystem_GL.so.  System Error:
/usr/local/lib/OGRE/RenderSystem_GL.so: cannot open shared object file: No such
file or directory in DynLib::load at OgreDynLib.cpp (line 80)

Expected results:
(the output is alot longer and has been truncated)
[paulr@radon ogre]$ /usr/lib/OGRE/Samples/Grass 
Creating resource group General
Creating resource group Internal
Creating resource group Autodetect
SceneManagerFactory for type 'DefaultSceneManager' registered.
Registering ResourceManager for type Material
Registering ResourceManager for type Mesh
Registering ResourceManager for type Skeleton
MovableObjectFactory for type 'ParticleSystem' registered.
OverlayElementFactory for type Panel registered.
OverlayElementFactory for type BorderPanel registered.
OverlayElementFactory for type TextArea registered.
Registering ResourceManager for type Font
ArchiveFactory for archive type FileSystem registered.
ArchiveFactory for archive type Zip registered.
DevIL version: Developer's Image Library (DevIL) 1.6.8pre Aug 22 2007
DevIL image formats: bmp dib cut dcx dds gif hdr ico cur jpg jpe jpeg lif mdl
mng jng pcx pic pix png pbm pgm pnm ppm psd pdd psp pxr sgi bw rgb rgba tga vda
icb vst tif tiff wal xpm raw 
DDS codec registering
Registering ResourceManager for type HighLevelGpuProgram
Registering ResourceManager for type Compositor
MovableObjectFactory for type 'Entity' registered.
MovableObjectFactory for type 'Light' registered.
MovableObjectFactory for type 'BillboardSet' registered.
MovableObjectFactory for type 'ManualObject' registered.
MovableObjectFactory for type 'BillboardChain' registered.
MovableObjectFactory for type 'RibbonTrail' registered.
Loading library /usr/lib/OGRE/RenderSystem_GL.so
Installing plugin: GL RenderSystem
OpenGL Rendering Subsystem created.
Plugin successfully installed
Loading library /usr/lib/OGRE/Plugin_ParticleFX.so
Installing plugin: ParticleFX
Particle Emitter Type 'Point' registered
Particle Emitter Type 'Box' registered
Particle Emitter Type 'Ellipsoid' registered
Particle Emitter Type 'Cylinder' registered
Particle Emitter Type 'Ring' registered
Particle Emitter Type 'HollowEllipsoid' registered
Particle Affector Type 'LinearForce' registered
Particle Affector Type 'ColourFader' registered
Particle Affector Type 'ColourFader2' registered
Particle Affector Type 'ColourImage' registered
Particle Affector Type 'ColourInterpolator' registered
Particle Affector Type 'Scaler' registered
Particle Affector Type 'Rotator' registered
Particle Affector Type 'DirectionRandomiser' registered
Particle Affector Type 'DeflectorPlane' registered
Plugin successfully installed
Loading library /usr/lib/OGRE/Plugin_BSPSceneManager.so
Installing plugin: BSP Scene Manager
Plugin successfully installed
Loading library /usr/lib/OGRE/Plugin_OctreeSceneManager.so
Installing plugin: Octree & Terrain Scene Manager
Plugin successfully installed
*-*-* OGRE Initialising
*-*-* Version 1.4.5 (Eihort)


Additional info:
Comment 1 Hans de Goede 2007-11-12 05:23:20 EST
You are not supposed to execute random binaries which are not int $PATH and then
expect things to work. Esp. not in this case since those binaries expect to be
able to write to the cwd, so this will probably only work as root.

The ogre-samples package ships with a script called Ogre-Samples, which will
generate a correct plugins.cfg and executes all the plugins one by one in such a
way that they will work for a normal user too.

I agree that executing them all may be inconvenient. So I've modified the script
to take the names of which Sample(s) to execute on the cmdline.

I also agree that the shipped plugins.cfg is broken, it will no longer be
shipped in the next release.

The below version has been build for rawhide and will show up in the next
rawhide push, considering the minor nature of this bug (if one uses Ogre-Samples
as intended), I'm not going to push this as an update for F-8 / F-7.

* Mon Nov 12 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 1.4.5-2
- Ogre-Samples now takes the name of which samples to run as arguments, if no
  arguments are provided, it will run all of them like it used too (bz 377011)
- Don't install a useless / broken plugins.cfg in the Samples folder,
  Ogre-Samples will generate a correct one when run (bz 377011)


Note You need to log in before you can comment on or make changes to this bug.