Bug 377061 - update policy of compat-libf2c
update policy of compat-libf2c
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: compat-gcc-32 (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-11 23:25 EST by Mario Lizier
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-12 11:19:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mario Lizier 2007-11-11 23:25:00 EST
Description of problem:
I have installed the compat-gcc-32 package and the library compat-libf2c-32.
Both packages are from Fedora Core 5. Since last rpm's list package
synchronization, it is appearing as update the package compat-libf2c-34. I
cannot update this package, and I do not think that this behavior is right. I
think that it needs to be like compat-gcc-34, that it is not a update of the
package compat-gcc-32. (I do not know if the problem is with 32 or 34 descriptions).

Version-Release number of selected component (if applicable):
compat-libf2c-32
compat-libf2c-34

How reproducible:
Install a compat-libf2c-32 and ask to list all upgradeable packages. It will
appear the compat-libf2c-34 as an update package. 


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
I think compats group packages cannot make interferences between other groups,
like 32 and 34, only in the own group. 

Additional info:
Comment 1 Jakub Jelinek 2007-11-12 07:07:03 EST
They of course have to conflict, when they install the same file.
See e.g. /usr/lib*/libg2c.so.0 in both compat-libf2c-32 and compat-libf2c-34.
Comment 2 Mario Lizier 2007-11-12 11:01:57 EST
Yes, but my question is not about how to install both packages.
The problem is that if you have compat-libf2c-32, the yum will try to update to
compat-libf2c-34, and this is wrong (I think).
To me, compat-libf2c-32 version 3.2.3 (for example) is an update of the package
compat-lib2fc-32 version 3.2.2, like the compat-libf2c-34 version 3.4.5 is an
update of package compat-libf2c-34 version 3.4.3, but it is not an update of the
package compat-libf2c-32 of any version (although the version is greater, but
when you installed an compat package, you really want this specifically version,
like 3.2 "family".

Please, correct me if I am wrong, but I think that this is the specked behavior.
If it is not true, the yum need to be able to uninstall compat-gcc-32 and
compat-libf2c-32 and after this, install compat-gcc-34 and compat-libf2c-34.


(In reply to comment #1)
> They of course have to conflict, when they install the same file.
> See e.g. /usr/lib*/libg2c.so.0 in both compat-libf2c-32 and compat-libf2c-34.

Comment 3 Jakub Jelinek 2007-11-12 11:19:20 EST
You don't understand the "can't have both installed, because they conflict" fact.
So the obsoletes is the only reasonable solution.  Please stop reopening this.
Comment 4 Mario Lizier 2007-11-12 11:32:54 EST
Sorry, but I think that you do not read my question. I am NOT trying to install
both packages. I know about this conflict. I do not want the compat-*-34 (of any
packages).
But the if the compat-libf2c-32 is obsoletes (by compat-libf2c-34), the
compat-gcc-32 is obsoletes by compat-gcc-34 too ! and this is not true ! some
code cannot be compiled with gcc-34 !

please, read the full question before answer. I think I was very clear that I do
not want to have the both package installed.


(In reply to comment #3)
> You don't understand the "can't have both installed, because they conflict" fact.
> So the obsoletes is the only reasonable solution.  Please stop reopening this.


Note You need to log in before you can comment on or make changes to this bug.