Bug 377081 - lsdasd does not list all dasds passed as arguments
lsdasd does not list all dasds passed as arguments
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: s390utils (Show other bugs)
4.5
All Linux
low Severity low
: ---
: ---
Assigned To: Phil Knirsch
Brock Organ
:
Depends On:
Blocks: 458670
  Show dependency treegraph
 
Reported: 2007-11-12 00:43 EST by Norm Murray
Modified: 2015-03-04 20:19 EST (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2008-0778
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 16:08:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to correct problem. (2.09 KB, patch)
2007-11-12 00:43 EST, Wade Mealing
no flags Details | Diff

  None (edit)
Description Wade Mealing 2007-11-12 00:43:11 EST
Description of problem:

When using lsdasd, it does not show all dasds in the parameter list, it seems to
only show the last.

From the man page:

lsdasd 0.0.0193 0.0.0195 it should show data for the given devices (if online).

Instead in practice, it only shows the last device on the command line.

Version-Release number of selected component (if applicable):

   Machine type (p650, x235, SF2, etc.):System Z
   Cpu type (Power4, Power5, IA-64, etc.):2094

How reproducible:

Every time

Actual results:

Only the last dasd is shown.

Expected results:

Every dasd that is online and specified on the command line as an argument to be
shown.


Additional info:
Comment 1 Wade Mealing 2007-11-12 00:43:44 EST
Created attachment 254981 [details]
Patch to correct problem.
Comment 2 RHEL Product and Program Management 2007-11-28 22:55:30 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 6 Phil Knirsch 2008-04-08 09:29:39 EDT
Test packages can be found here:

http://people.redhat.com/pknirsch/downloads/s390utils/s390utils-1.3.2-2.40.16

Read ya, Phil
Comment 8 Brock Organ 2008-05-14 14:00:32 EDT
verified fix using s390utils-1.3.2-2.40.16 (tree is RHEL4-U7-re20080507.0
s390-AS, s390x-AS) ...

> # lsdasd 0.0.3021
> 0.0.3021(ECKD) at ( 94:  0) is dasda      : active at blocksize 4096, 601020
blocks, 2347 MB
> # lsdasd 0.0.3021 0.0.3121
> 0.0.3021(ECKD) at ( 94:  0) is dasda      : active at blocksize 4096, 601020
blocks, 2347 MB
> 0.0.3121(ECKD) at ( 94:  4) is dasdb      : active at blocksize 4096, 601020
blocks, 2347 MB
> # lsdasd 0.0.3021 0.0.3121 0.0.3421
> 0.0.3021(ECKD) at ( 94:  0) is dasda      : active at blocksize 4096, 601020
blocks, 2347 MB
> 0.0.3121(ECKD) at ( 94:  4) is dasdb      : active at blocksize 4096, 601020
blocks, 2347 MB
> 0.0.3421(ECKD) at ( 94: 16) is dasde      : active at blocksize 4096, 601020
blocks, 2347 MB
> # 
Comment 10 Issue Tracker 2008-06-10 09:45:03 EDT
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |akumar34@in.ibm.com




------- Additional Comments From rajduddu@in.ibm.com  2008-06-10 07:40 EDT
-------
Hi,
In RHEL4.7, still lsdasd has problem with '-s' option.
Log:
[root@t6315022 ~]# uname -a
Linux t6315022.boeblingen.de.ibm.com 2.6.9-71.EL #1 SMP Tue May 27
16:35:52 EDT
2008 s390 s390 s390 GNU/Linux
[root@t6315022 ~]# lsdasd
0.0.4c75(ECKD) at ( 94:  4) is dasdb      : active at blocksize 4096,
1202040
blocks, 4695 MB
0.0.4c76(ECKD) at ( 94:  8) is dasdc      : active at blocksize 4096,
1202040
blocks, 4695 MB
0.0.4c77(ECKD) at ( 94: 12) is dasdd      : active at blocksize 4096,
1202040
blocks, 4695 MB
0.0.4c74(ECKD) at ( 94: 16) is dasde      : active at blocksize 4096,
1202040
blocks, 4695 MB
0.0.fba1(FBA ) at ( 94: 20) is dasdf      : active at blocksize 512,
1000000
blocks, 488 MB
[root@t6315022 ~]# lsdasd -s
0.0.4c75(ECKD) at ( 94:  4) is dasdb      : active at blocksize 4096,
1202040
blocks, 4695 MB
0.0.4c76(ECKD) at ( 94:  8) is dasdc      : active at blocksize 4096,
1202040
blocks, 4695 MB
0.0.4c77(ECKD) at ( 94: 12) is dasdd      : active at blocksize 4096,
1202040
blocks, 4695 MB
0.0.4c74(ECKD) at ( 94: 16) is dasde      : active at blocksize 4096,
1202040
blocks, 4695 MB
0.0.fba1(FBA ) at ( 94: 20) is dasdf      : active at blocksize 512,
1000000
blocks, 488 MB
[root@t6315022 ~]# lsdasd -s 4c77 4c76 4c75 
4c75(ECKD) at ( 94:  4) is dasdb      : active at blocksize 4096, 1202040
blocks, 4695 MB
[root@t6315022 ~]# lsdasd  4c77 4c76 4c75 
0.0.4c77(ECKD) at ( 94: 12) is dasdd      : active at blocksize 4096,
1202040
blocks, 4695 MB
0.0.4c76(ECKD) at ( 94:  8) is dasdc      : active at blocksize 4096,
1202040
blocks, 4695 MB
0.0.4c75(ECKD) at ( 94:  4) is dasdb      : active at blocksize 4096,
1202040
blocks, 4695 MB

Thanks
Rajasekhar Duddu. 


This event sent from IssueTracker by jkachuck 
 issue 137243
Comment 12 Issue Tracker 2008-06-13 11:54:34 EDT
File uploaded: s390-tools-1.3.2-lsdasd.patch

This event sent from IssueTracker by jkachuck 
 issue 137243
it_file 137814
Comment 13 Issue Tracker 2008-06-13 11:54:36 EDT
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
              Owner|HJPICHTOLDACCOUNT@de.ibm.com|hans@de.ibm.com
             Status|SUBMITTED                   |ASSIGNED
         Resolution|FIX_BY_IBM                  |




------- Additional Comments From hans@de.ibm.com (prefers email at
hans@linux.vnet.ibm.com)  2008-06-13 11:16 EDT -------
 
s390-tools-1.3.2-lsdasd.patch 


This event sent from IssueTracker by jkachuck 
 issue 137243
Comment 14 Issue Tracker 2008-06-13 11:54:36 EDT
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|ASSIGNED                    |FIXEDAWAITINGTEST
         Resolution|                            |FIX_BY_IBM




------- Additional Comments From hans@de.ibm.com (prefers email at
hans@linux.vnet.ibm.com)  2008-06-13 11:20 EDT -------
The previous patch IBM provided was not correctly integrated into the
s390utils
package.

Therefor the problem still exits.
Attached you'll find s390-tools-1.3.2-lsdasd.patch.

If you apply this patch on top of the src.rpm provided on Phil's website
at
http://people.redhat.com/pknirsch/downloads/s390utils/s390utils-1.3.2-2.40.16
the problem is fixed (this is the same src.rpm as the one contained in
the
lasted rhel4.7 snapshots).

Regards,

Hans 


This event sent from IssueTracker by jkachuck 
 issue 137243
Comment 15 errata-xmlrpc 2008-07-24 16:08:28 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0778.html
Comment 16 Issue Tracker 2008-07-30 09:10:10 EDT
------- Comment From schamart@in.ibm.com 2008-07-30 01:46 EDT-------
Hi Hans,
The problem is still not resolved. The patch is still not into the distro.
We
checked in the GA kernel 2.6.9-78 kernel of RHEL4.7. My team manually
updated
the patch to lsdasd and then checked if the patch is working. This problem
needs
to be reopened.

As per Comment #37 the patch is included in
http://people.redhat.com/pknirsch/downloads/s390utils/s390utils-1.3.2-2.40.16.
The s390utils version in GA is also s390utils-1.3.2-2.40.16 Somehow the
patch is
not in.

Reopening the Bugzilla.


This event sent from IssueTracker by jkachuck 
 issue 137243

Note You need to log in before you can comment on or make changes to this bug.