Bug 37714 - /sbin/ppp-watch hangs for USB Ricochet/GS
Summary: /sbin/ppp-watch hangs for USB Ricochet/GS
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 7.1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-26 01:26 UTC by Bertil Askelid
Modified: 2014-03-17 02:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-26 02:04:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bertil Askelid 2001-04-26 01:26:39 UTC
Connecting the Ricochet/GS modem to the USB port and then start a PPP
connection. The connection comes up and the outside world is pingable, but
the /sbin/ppp-watch program hangs. Here is a debug printout from the
/etc/sysconfig/network-scripts/ifup-ppp. The fail at the end is caused by
me, a first C-c causes a PPP disconnect, a second C-c causes exit from
ppp-watch and the "Failed to activate ..." printout:

+ PATH=/sbin:/usr/sbin:/bin:/usr/bin
+ cd /etc/sysconfig/network-scripts
+ . network-functions
+ . /etc/rc.d/init.d/functions
++ TEXTDOMAIN=initscripts
++ TEXTDOMAINDIR=/etc/locale
++ umask 022
++ export PATH=/sbin:/usr/sbin:/bin:/usr/bin:/usr/X11R6/bin
++ PATH=/sbin:/usr/sbin:/bin:/usr/bin:/usr/X11R6/bin
++ '[' -z '' ']'
++ COLUMNS=80
++ '[' -f /etc/sysconfig/i18n -a -z '' ']'
++ . /etc/sysconfig/i18n
+++ LANG=en_US
+++ SUPPORTED=en_US:en
+++ SYSFONT=koi8-8x8
+++ SYSFONTACM=iso01
+++ /sbin/consoletype
++ '[' en_US = ja_JP.eucJP -a pty '!=' pty ']'
++ export LANG
++ '[' -z '' ']'
++ '[' -f /etc/sysconfig/init ']'
++ . /etc/sysconfig/init
+++ BOOTUP=color
+++ RES_COL=60
+++ MOVE_TO_COL=echo -en \033[60G
+++ SETCOLOR_SUCCESS=echo -en \033[1;32m
+++ SETCOLOR_FAILURE=echo -en \033[1;31m
+++ SETCOLOR_WARNING=echo -en \033[1;33m
+++ SETCOLOR_NORMAL=echo -en \033[0;39m
+++ LOGLEVEL=1
+++ PROMPT=yes
++ '[' -x /sbin/consoletype ']'
+++ consoletype
++ '[' pty = serial ']'
++ '[' color '!=' verbose ']'
++ INITLOG_ARGS=-q
+ '[' ifcfg-ppp2 = daemon ']'
++ basename ifcfg-ppp2
+ CONFIG=ifcfg-ppp2
+ '[' -f ifcfg-ppp2 ']'
+ source_config
++ basename ifcfg-ppp2
++ sed 's/^ifcfg-//g'
+ DEVNAME=ppp2
+ basename ifcfg-ppp2
+ grep '[^g]-'
+ . ifcfg-ppp2
++ DEVICE=ppp2
++ PERSIST=yes
++ DEFROUTE=yes
++ INITSTRING=ATZ
++ MODEMPORT=/dev/ttyACM0
++ LINESPEED=460800
++ ESCAPECHARS=no
++ DEFABORT=yes
++ HARDFLOWCTL=yes
++ PPPOPTIONS=
++ DEBUG=no
++ PAPNAME=
++ REMIP=
++ IPADDR=
++ MTU=
++ MRU=
++ DISCONNECTTIMEOUT=
++ RETRYTIMEOUT=
++ BOOTPROTO=none
++ ONBOOT=no
++ USERCTL=yes
+ exec /sbin/ppp-watch ppp2 ifcfg-ppp2
Failed to activate ppp2 with error 32

Comment 1 Bill Nottingham 2001-04-26 01:46:29 UTC
ppp-watch is supposed to be synchronous; it's supposed to stay running
while the ppp connection is up. Or am I missing something about your
report?

Comment 2 Bertil Askelid 2001-04-26 02:04:37 UTC
You're absolutely right. I was calling my script that does /sbin/ifup without
spawning it, just waiting for the result. Easily changed. However, it did work
in 7.0.

Sorry for the confusion, and thanks a lot for the quick answer!!!


Note You need to log in before you can comment on or make changes to this bug.