Bug 377211 - TAHI--DHCPv6--When having rfc3646 tests by the self_test tool from TAHI, almost all the tests fail
TAHI--DHCPv6--When having rfc3646 tests by the self_test tool from TAHI, almo...
Status: CLOSED DUPLICATE of bug 376871
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dhcpv6 (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks: 253764
  Show dependency treegraph
 
Reported: 2007-11-12 02:19 EST by Zhiyong Wu
Modified: 2007-12-28 00:39 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-28 00:39:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zhiyong Wu 2007-11-12 02:19:35 EST
Description of problem:

  When having dhcpv6 tests for rfc3646 in the server mode,we found that all the 

tests fail in some scenarios.

Version-Release number of selected component (if applicable):

  kernel-2.6.18-43.el5

Software Environment:   
  Testee(NUT):   
    RHEL5 
    Kernel:2.6.18-43.el5 
   
  Tester(TN):   
    FreeBSD6.2
    v6eval-3.0.12.tar.gz
   
TAHI package:    
  DHCPv6_Self_Test_P2_1_0_7.tar.gz

How reproducible:
  every time

Steps to Reproduce:    
  1. Configure TAHI test environment.     
  2. Run the TAHI test suite     
  3. After the test completes, check for the results 
  
Actual results:

   Almost all the tests fail. 

Expected results:

   All the tests should succeed.

Additional info:

   NUT is set to the server mode
  
   please refer to

http://focus.brisbane.redhat.com/~zwu/dhcp_server/20071101/DHCPv6_Self_Test_P2_1_0_7_server/rfc3646/index.html
Comment 1 Zhiyong Wu 2007-11-12 02:34:32 EST
   Also about it:

   when NUT is set to the server mode, and for rfc3736

   the failing reason should be the same as the bug

   pls refer to the url below:

http://focus.brisbane.redhat.com/~zwu/dhcp_server/20071101/DHCPv6_Self_Test_P2_1_0_7_server/rfc3736/index.html

   (1)2	Basic Message Exchange

   (2)3	Transaction ID Consistency

   (3)4	Part A : Valid UDP port

   (4)6	Part A : Client/Server Message Format

   (5)8	Server Identifier Option Format

   (6)9	Part A : DUID based on Link-layer Address Plus Time [DUID-LLT] Format

   (7)10	Part B : DUID based on Link-layer Address Plus Time [DUID-LLT] Consistency

   (8)15	DNS Recursive Name Server Option Format

   (9)16	Domain Search List Option Format

   (10)19	Part A :Returning of DNS Recursive Name Server option

   (11)20	Part B :Returning of DNS Recursive Name Server option and Domain
Search List Option

   (12)21	Part A : Reply message transmission

   (13)22	Part B : Reply message in response to Information-request message with
ORO(DNS Recursive Name Server option)

   (14)23	Part C : Reply message in response to Information-request message with
ORO(Domain Search List option)

Comment 2 RHEL Product and Program Management 2007-11-15 04:04:53 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Zhiyong Wu 2007-12-28 00:38:47 EST
the bug has been tested with dhcpv6-1.0.4-1.el5.i386.rpm 
dhcpv6-client-1.0.4-1.el5.i386.rpm  libdhcp6client-1.0.4-1.el5.i386.rpm.

Found that the following tests fail.

http://focus.brisbane.redhat.com/~zwu/RHEL5.1-Server-20071017.0/20071225/DHCPv6_Self_Test_P2_1_0_8_client/rfc3646/index.html

   (8)15	DNS Recursive Name Server Option Format

   (9)16	Domain Search List Option Format

But the problem has been reported in bug376871

so keep track of the above two failing tests by bug376871 and put this bug into
MODIFIED
Comment 4 Zhiyong Wu 2007-12-28 00:39:58 EST

*** This bug has been marked as a duplicate of 376871 ***

Note You need to log in before you can comment on or make changes to this bug.