Bug 377261 - system-config-network repeated save changes request
system-config-network repeated save changes request
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
8
i686 Linux
low Severity low
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
: 401921 408191 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-12 03:47 EST by Marc
Modified: 2008-01-12 16:12 EST (History)
5 users (show)

See Also:
Fixed In Version: 1.4.7-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-11 17:20:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Netwrok screenshot (52.42 KB, image/pjpeg)
2007-11-14 04:37 EST, Marc
no flags Details
error trace from failure (3.78 KB, text/plain)
2007-12-12 19:22 EST, Ray Todd Stevens
no flags Details
run from a failed attempt to run a yum update against the testing repo (3.59 KB, text/plain)
2007-12-13 11:42 EST, Ray Todd Stevens
no flags Details

  None (edit)
Description Marc 2007-11-12 03:47:13 EST
Description of problem: 

When accessing the modem in Gnome, the network access window keeps saying 
changes have been made, and requests if I want to save them, even when no 
changes have been made, except for when first configuring the device.  This 
occurs when activating and deactivating the device, as well as when closing the 
application.  After clicking to save changes, even when changes haven't been 
made, the modem does function, and connects to the ISP.  This did not happen 
under FC6 or F7.  KPPP is fine.


Version-Release number of selected component (if applicable):

Fedora 8, system-config-network (modem set-up)


How reproducible:

Always, even when after a reboot.


Steps to Reproduce:
1.  Accessed modem and logged into network - save changes window appeared at 
each stage.
2.  Shutdown system and tried again - same problem.
3.  Repeat of step 2, same problem.
  
Actual results:


Expected results:


Additional info:
Comment 1 Harald Hoyer 2007-11-13 07:17:44 EST
system-config-network-1.4.5-1.fc8 has been pushed to the Fedora 8 testing
repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-network'
Comment 2 Marc 2007-11-14 04:06:04 EST
Hello,

Tested the update, and the problem still presents itself, i.e., save changes 
window appeared at each stage.  Prior to installing the test update, it failed 
on the dependency, which was found on the F8 dvd and installed (htmlview-4.0.0-
3.fc7.noarch.rpm):

[root@localhost ~]# rpm -Fvh *.rpm 
error: Failed dependencies: 
        /usr/bin/htmlview is needed by system-config-network-1.4.5-1.fc8.noarch 
[root@localhost ~]# rpm -Uvh htmlview-4.0.0-3.fc7.noarch.rpm 
Preparing...                ########################################### [100%] 
   1:htmlview               ########################################### [100%] 
[root@localhost ~]# 

Also installed at the same time was the test update system-config-network-tui-
1.4.5-1.fc8.noarch.rpm

Comment 3 Harald Hoyer 2007-11-14 04:21:08 EST
The dependency is correct (was added).

Hmm, only starting s-c-network and closing asks for a "save"? Can't reproduce
this anymore.
Comment 4 Marc 2007-11-14 04:37:56 EST
Created attachment 257821 [details]
Netwrok screenshot
Comment 5 Marc 2007-11-14 04:42:14 EST
When opening Network Configuration for the first time, there is no prompt for 
saving changes.  The prompts start when the 'activate' button is clicked, and 
from then onwards until the Network Configuration window is closed.  The modem 
connects and functions.  Hope the screenshot just sent, and these comments help.

Marc.
Comment 6 Harald Hoyer 2007-11-14 04:47:01 EST
I will investigate. Thanks.
Comment 7 Harald Hoyer 2007-11-28 04:25:04 EST
*** Bug 401921 has been marked as a duplicate of this bug. ***
Comment 8 Harald Hoyer 2007-12-03 05:09:50 EST
*** Bug 408191 has been marked as a duplicate of this bug. ***
Comment 9 Ray Todd Stevens 2007-12-05 18:10:28 EST
I have seen this same problem, but it appears if you have modified the settings.
  Then apparently the save of the settings doesn't reset the "modified" flag. 
So everytime you do something that relates to these settings it assumes that
they are still in a "modified" status and asks you to save them again.   

This is a definately change from fc7 and even with current updates fc7 doesn't
do this.
Comment 10 Fedora Update System 2007-12-06 15:44:38 EST
system-config-network-1.4.7-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-network'
Comment 11 Ray Todd Stevens 2007-12-07 14:35:48 EST
Interesting when I try to do this update and test it I get 1.4.5-1    Which is
definitely not fixed.
Comment 12 Harald Hoyer 2007-12-10 05:50:42 EST
wait until your mirror syncs
Comment 13 Marc 2007-12-10 13:59:07 EST
Test system-config-network-1.4.7-1.fc8 package installed (including the test
system-config-network-tui package), and the problem of repeated requests for
saving changes when clicking activate and deactivate buttons have now stopped.
Test packages seem to be okay.

Thanks,

Marc.
Comment 14 Ray Todd Stevens 2007-12-11 10:43:08 EST
OK I had to wait for the mirror update.   Now it works.  I have tested this, and
it certainly seems ready for prime time.   It might be good to indicate in the
message regarding the placement in the repo of the update some information about
how long it normally takes for the mirrors to have it.
Comment 15 Ray Todd Stevens 2007-12-12 19:22:16 EST
Created attachment 286401 [details]
error trace from failure

Hey this worked on three machines, but now I get an error on an additional
unit.	Here is the error trace.
Comment 16 Jiri Moskovcak 2007-12-13 04:43:22 EST
It's caused by missing "%" on the line 41 it should be: 
error += "Wrong: %s in entry %i" % (e.message,num)

Could you please post your /etc/hosts file from that machine?

Jirka
Comment 17 Ray Todd Stevens 2007-12-13 07:57:35 EST
# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1       localhost.localdomain   localhost
10.10.1.20      scribe  ruth
216.9.147.189   jeremiah        jeremiah.netmedoffice.com.     
jeremiah.medbulletin.com.
216.9.147.175   isaiah  isaiah.netmedoffice.com.        isaiah.medbulletin.com.
216.9.147.185   ezekiel ezekiel.netmedoffice.com.       ezekiel.medbulletin.com.
216.9.147.188   joel    joel.netmedoffice.com.  joel.medbulletin.com.
216.9.147.176   amos    amos.netmedoffice.com.  amos.medbulletin.com.
216.9.147.178   hosea   hosea.netmedoffice.com. hosea.medbulletin.com.
netmedoffice.com www.netmedoffice.com
216.9.147.179   test    test.netmedoffice.com
216.9.147.172   peter   peter.netmedoffice.com. peter.medbulletin.com.
216.9.147.161   ns1     ns1.medbulletin.com. www.safespeak.com. router 
216.9.147.180   www.medbulletin.com.    medbulletin.com.
10.200.0.1      dslrouter
10.200.0.11     bridge-pl
10.200.0.12     bridge.mb
66.244.119.241  joshua
10.10.1.4       aqueduct-internal aqueduct
216.9.147.173   john.netmedoffice.com.  john
10.200.0.10     joshua-wireless
10.200.0.11     bridge-pl
10.200.0.12     bridge-mb
10.200.0.13     router-wireless
63.250.69.195   egixfeed
216.9.146.67    kivafeed
Comment 18 Ray Todd Stevens 2007-12-13 08:07:56 EST
Actually I may have found an additional problem.  

Before I tested the new version all of my host files were the same, like this
one.   Now I have a bunch of them that have problems because entires keep being
duplicated.

Pay attention the the bridge lines, joel and john 

# Do not remove the following line, or various programs
# that require network functionality will fail.


127.0.0.1       localhost.localdomain   localhost
10.10.1.20      scribe  ruth
216.9.147.189   jeremiah        jeremiah.netmedoffice.com.     
jeremiah.medbulletin.com.
216.9.147.175   isaiah  isaiah.netmedoffice.com.        isaiah.medbulletin.com.
216.9.147.185   ezekiel ezekiel.netmedoffice.com.       ezekiel.medbulletin.com.
216.9.147.188   joel    joel.netmedoffice.com.  joel.medbulletin.com.     
joel.netmedoffice.com.  joel.medbulletin.com.    joel.netmedoffice.com. 
joel.medbulletin.com.    joel.netmedoffice.com.  joel.medbulletin.com.   
joel.netmedoffice.com.  joel.medbulletin.com.
216.9.147.176   amos    amos.netmedoffice.com.  amos.medbulletin.com.
216.9.147.178   hosea   hosea.netmedoffice.com. hosea.medbulletin.com. 
netmedoffice.com        www.netmedoffice.com
216.9.147.179   test    test.netmedoffice.com
216.9.147.172   peter   peter.netmedoffice.com. peter.medbulletin.com.
216.9.147.161   ns1     ns1.medbulletin.com.    www.safespeak.com.      router 
ns1     ns1.medbulletin.com.  ns1     ns1.medbulletin.com.  ns1    
ns1.medbulletin.com.  ns1     ns1.medbulletin.com.  ns1     ns1.medbulletin.com.
 ns1     ns1.medbulletin.com.  ns1     ns1.medbulletin.com.
216.9.147.180   www.medbulletin.com.    medbulletin.com.
10.200.0.1      dslrouter
10.200.0.11     bridge-pl       bridge-pl       bridge-pl       bridge-pl
10.200.0.12     bridge.mb       bridge-mb       bridge.mb       bridge-mb
66.244.119.241  joshua
10.10.1.4       aqueduct-internal       aqueduct
216.9.147.173   john.netmedoffice.com.  john  john  john  john  john  john  john
10.200.0.10     joshua-wireless
10.200.0.11     bridge-pl       bridge-pl       bridge-pl       bridge-pl
10.200.0.12     bridge.mb       bridge-mb       bridge.mb       bridge-mb
10.200.0.13     router-wireless
63.250.69.195   egixfeed
216.9.146.67    kivafeed

Every time I run the program I get one or more of these duplications.   I have
not even edited the hosts.   Heck I have not even accessed that tab.   But if I
do a save these strange things happen.
Comment 19 Jiri Moskovcak 2007-12-13 08:31:12 EST
Thank you. I'm going to check it.

Jirka
Comment 20 Jiri Moskovcak 2007-12-13 09:37:28 EST
Hm, that's weird, I can't reproduce it whit your hosts file. I get the 
exception, but no duplications. Even if I fix the bug and remove the exception 
which prevents saving hosts file. Are you sure, you have the 1.4.7-1 version of 
the s-c-n? If so, could you please describe what exactly you have to do get 
these duppes?

Thanks

jirka
Comment 21 Ray Todd Stevens 2007-12-13 10:58:11 EST
I am not sure I will look into the duplicates more.   This is occurring on the
other machines and not the one giving the exception.   But they all were
upgraded to 1.4.7-1.   That is why included it here.

The good news is that the original problem seems to definitely be fixed.
Comment 22 Ray Todd Stevens 2007-12-13 11:26:12 EST
Interesting I am also having trouble duplicating it.   One of the issues may be
in the repos.

Interestingly enough on one of the machines experiencing this I have a different
version of the root app (7-1) and the tui (5-1), which shouldn't happen.

On another of the machines it turns out I was running 3-1 even after having run
an update and it said that I was upgraded to 7-1 on both apps.   When I try and
go back and do an update on that machine using the updates-testing repo it ways
I have nothing to do, and a search of the updates-testing repo on that mirror
shows no system-config-network rpms at all.

This is beginning to look like a whole separate issue.

If it helps any in figuring anything out.   The actual processes being done were
to change the ips to a new net block on a couple of servers, boot enabling and
setting static ips on two more, and disabling interfaces as boot on interfaces
on an additional server.

Comment 23 Ray Todd Stevens 2007-12-13 11:42:18 EST
Created attachment 287591 [details]
run from a failed attempt to run a yum update against the testing repo

This is what I get after doing a yum clean all if I run against the testing
repo on a machine running 3-1 as the system-config-network rpm.   Interestingly
enough yum update also does nothing?????
Comment 24 Jiri Moskovcak 2007-12-13 11:55:08 EST
Try to update system-config-network-tui or complete reinstall:

$ yum remove system-config-tui
$ yum --enablerepo=updates-testing install system-config-network

But version 1.4.7-1 has the bug with the exception mentioned above. It will 
prevent you from saving. It's caused by the trailing '.' you use in hostnames. 
I'll fix it in next release.

Jirka
Comment 25 Ray Todd Stevens 2007-12-14 00:16:54 EST
Interesting.   I will research farther.   In the mean time I sure could pull the
dots easy enough.
Comment 26 Marc 2007-12-14 04:56:42 EST
Just been following this thread with interest over the last couple of days, and
note the following in case it helps you with the forthcoming update.

1) The system-config-network-1.4.7-1.fc8 package functions on my machine
(including the tui package), and I connect to my ISP via serial modem without
any problems.

2) I haven't yet tried to save any new connection details, but note your
comments about saving being prevented with this current test package (the
previous saved data must still be there, as the modem still connects when
"activate" is clicked).

3) I looked in  my /etc/hosts file, and it was practically empty, except for
something at the top of the details, which are very similar to the one posted
above, and which I'll copy here for your reference, as I didn't get time to take
a copy of my own /etc/hosts file (this is not exactly like mine, but is near
enough for information purposes):

# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1       localhost.localdomain   localhost

4) I install all my updates through the terminal in root, so haven't experienced
the problems with yum, but both the system-config-network-1.4.7-1.fc8 test
updates installed without any errors coming up (with the first
system-config-network-1.4.5-1.fc8 test, it asked for the dependency
htmlview-4.0.0-3.fc7.noarch.rpm, which I installed after finding it from the F8
DVD, so I don't know if the system-config-network-1.4.7-1.fc8 test package, and
the forthcoming one, need this dependency as well).

Hope this helps with the updated test package.

Marc.
Comment 27 Ray Todd Stevens 2007-12-14 10:21:28 EST
There appears to be some kind of a problem with the mirrors is the reasons that
I get the mismatch in versions.    From what I can tell the reasons for the lack
of an update of the tui stuff is that it is missing from the mirrors these
machines are using.   Other mirrors don't still seem to have any of the
system-config-network stuff in the updates-testing repo.

Right now I can't tell which mirrors that my machines are actually using.   Is
there some way to do that?

Incidentally the machines which have had the problem with the duplicates also
appear to have the mismatched tui and main versions of the software.   I find
this extra interesting, because normally if a linked rpm like these two appear
to be linked to each other is not available then usually the upgrade errors out
and refuses to load instead of only loading half the install.
Comment 28 Marc 2007-12-14 10:39:00 EST
I don't use yum to update my machine due to my slow 56K modem connection, so I
rummage in my local mirrors for the latest updates, and download them all
regularly via another faster connection and do a freshen command in root.  

However, I've found local mirrors can occasionally be a day or so behind Red Hat
(either because the server is down or other reasons), which maybe could explain
some of your missing packages, so I also look in the main Red Hat repositories
(for update RPMs and testing RPMs), which is usually bang up-to-date:

http://download.fedora.redhat.com/pub/fedora/linux/updates/testing/8/i386/
Comment 29 Fedora Update System 2008-01-11 17:20:15 EST
system-config-network-1.4.7-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.