Bug 377441 - Installer over PXE: DHCP-Error: parse_option_buffer: option ... (255) larger than buffer.
Installer over PXE: DHCP-Error: parse_option_buffer: option ... (255) larger ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-12 05:26 EST by Florian Wicke
Modified: 2008-06-12 09:14 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-12 09:14:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian Wicke 2007-11-12 05:26:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8

Description of problem:
The installer is not able to get an ip-address over dhcp from the dhcp-server "bootp(bootptab)"

Version-Release number of selected component (if applicable):
Fedora7 (7.0, 7.91, 7,92) and Fedora8 (8.0) installer 

How reproducible:
Always


Steps to Reproduce:
1. Debian 4.0 tftp/bootp-server
tftpd: tftpd-hpa (debian repo)
bootpd: bootp (debian repo)
pxe config:
DEFAULT vnc-install/Fedora-8/vmlinuz
APPEND  initrd=vnc-install/Fedora-8/initrd.img vnc vncpassword=testing1 lang=de_DE keymap=de resolution=800x600 ip=dhcp method=http://ftp-stud.hs-esslingen.de/pub/fedora/linux/releases/8/  Fedora/i386/os/ ksdevice=bootif root=/dev/ram0 ro --

bootptab config:
host:ip=<ip>:ha=<mac>:sm=<netmask>:gw=<gateway>:ht=1:ds=<nameserver>:bf=pxelinux.0:td=/:sa=<tftpserver>:dl=172800

2. simply boot over pxe and accept dhcp-configuration(another bug.. installer asks if you want to configure network even if you did this in the commandline - but not our problem now)


Actual Results:
The installer is not able to get the ip-configuration over dhcp.
In the error-console are many errors:
ERROR: parsy_option_buffer opion router-solicitation-address (255) larger than buffer.
of sometimes
ERROR: parsy_option_buffer opion netbios-node-type (255) larger than buffer.

This error occurs NOT with the dhcp-server dhcpdv3 - only with bootp - but FedoraCore 6 and all other distributions and dhcp-clients work fine.

Expected Results:
The installer should become an ip-address and start the vnc-installation

Additional info:
INFO   : DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
ERROR  : parsy_option_buffer opion netbios-node-type (255) larger than buffer.
ERROR  : parsy_option_buffer opion netbios-node-type (255) larger than buffer.
ERROR  : parsy_option_buffer opion netbios-node-type (255) larger than buffer.
ERROR  : parsy_option_buffer opion netbios-node-type (255) larger than buffer.
INFO   : DHCPv4 eth0 - TIMED OUT

INFO   : DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
ERROR: parsy_option_buffer opion router-solicitation-address (255) larger than buffer.
ERROR: parsy_option_buffer opion router-solicitation-address (255) larger than buffer.
ERROR: parsy_option_buffer opion router-solicitation-address (255) larger than buffer.
ERROR: parsy_option_buffer opion router-solicitation-address (255) larger than buffer.
INFO   : DHCPv4 eth0 - TIMED OUT
Comment 1 Florian Wicke 2007-11-12 05:31:07 EST
Sorry for some misspellings.. the correct errors are:

ERROR  : parse_option_buffer option netbios-node-type (255) larger than buffer.
and
ERROR  : parse_option_buffer option router-solicitation-address (255) larger
than buffer.
Comment 2 Andy Lindeberg 2008-06-04 09:42:37 EDT
Have you encountered the same problem when installing Fedora 9?
Comment 3 Florian Wicke 2008-06-10 13:30:30 EDT
The problem is gone with Fedora 9. Thanks!

Note You need to log in before you can comment on or make changes to this bug.