Bug 377491 - Networking locks up after random time
Networking locks up after random time
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-12 05:51 EST by Huub
Modified: 2008-02-14 17:39 EST (History)
6 users (show)

See Also:
Fixed In Version: 2.6.23.15-137.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-14 17:39:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/dmesg (16.93 KB, text/plain)
2007-11-13 00:19 EST, Huub
no flags Details
kernel-2.6.23.1-49.fc8.x86_64 dmesg (22.85 KB, text/plain)
2007-11-18 06:06 EST, Tomasz Kepczynski
no flags Details
kernel-2.6.23.1-49.fc8.x86_64 with noapic option dmesg (22.89 KB, text/plain)
2007-11-18 06:07 EST, Tomasz Kepczynski
no flags Details
kernel-xen-2.6.21-2950.fc8.x86_64 dmesg (20.71 KB, text/plain)
2007-11-18 06:07 EST, Tomasz Kepczynski
no flags Details

  None (edit)
Description Huub 2007-11-12 05:51:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9

Description of problem:
After starting the pc all works well, but after a random time, I notice that the connection with the network is gone. Ping shows '...Destination Host Unreachable' and /var/log/messages shows 'kernel: NETDEV WATCHDOG: eth0: transmit timed out'.
The nic-chipset is RTL-8169.

Version-Release number of selected component (if applicable):
kernel-2.6.23.1-49.fc8

How reproducible:
Always


Steps to Reproduce:
1. start up the pc and log in
2. start any networking program
3. do anything in it until nothing happens anymore except the mouse-cursor keeps busy.

Actual Results:
The pc keeps running, without networking contact.

Expected Results:
Proceeding with download, positive results with ping.

Additional info:
Comment 1 Chuck Ebbert 2007-11-12 18:27:40 EST
Can you please attach /var/log/dmesg to this bugzilla?
Comment 2 Huub 2007-11-13 00:19:47 EST
Created attachment 256341 [details]
/var/log/dmesg
Comment 3 Edouard Bourguignon 2007-11-13 01:58:49 EST
I also loose network connection after a couple of hours
Host unreachable in syslog from named, this is on a remote hosted server so when
network is lost i can't do anything more to test... I just know that the kernel
is fine, just the network seems down
Nothing about watchdog here so maybe it's another bug?

Appears on:
kernel-2.6.23.1-49.fc8
kernel-2.6.23.1-42.fc8

The NIC is a "VIA Technologies, Inc. VT6120/VT6121/VT6122 Gigabit Ethernet
Adapter" on an Eden C7 2Ghz motherboard

I'm now back on the last F7 kernel and it works great (for the moment)
Comment 4 Chuck Ebbert 2007-11-13 14:55:14 EST
Adding cc: for maintainer.
Comment 5 Francois Romieu 2007-11-13 16:51:21 EST
Huub, is there a kernel version that you know is working with your 8169 ?
It would really help me.

Edouard, can you specify the working F7 kernel version ?

-- 
Ueimor
Comment 6 Tomasz Kepczynski 2007-11-13 18:02:51 EST
I've got exactly the same problem as the reporter. Architecture and
NIC match, kernel also matches. Simply starting thunderbird or firefox
kills network.
What's interesting is that xen kernel does not seem to have this
problem, I use kernel-xen-2.6.21-2950.fc8.x86_64.
Comment 7 Francois Romieu 2007-11-13 18:12:10 EST
Tomasz :
> I've got exactly the same problem as the reporter.

There are two reporters with different hardware (r8169 vs via-velocity).

Which one do you use ?

-- 
Ueimor
Comment 8 Tomasz Kepczynski 2007-11-14 00:31:05 EST
As the reporter: r8169 on amd64 with kernel-2.6.23.1-49.fc8.
Comment 9 Edouard Bourguignon 2007-11-14 04:22:34 EST
My working f7 kernel is:
kernel-2.6.23.1-21.fc7.i686
Comment 10 Edouard Bourguignon 2007-11-14 04:30:31 EST
My problem also looks like bug #377721 so i will try to boot with the noapic
kernel option
Comment 11 Francois Romieu 2007-11-15 17:27:27 EST
(answering Tomasz)

It looks like a kernel config difference (broken DAC again ?). Can you attach the
three kernel dmesgs please ?

kernel-2.6.23.1-49.fc8 and kernel-xen-2.6.21-2950.fc8.x86_64 could be enough but
the fc7 one will not hurt.

-- 
Ueimor
Comment 12 Tomasz Kepczynski 2007-11-18 06:05:54 EST
I will attach dmesg's below.
I've tried noapic option as suggested in comment #10 and
it seems to fix the problem (40GiB of traffic passed
through the interface without problem and usually I had
problems after 100-200MiB of traffic).
Comment 13 Tomasz Kepczynski 2007-11-18 06:06:55 EST
Created attachment 262801 [details]
kernel-2.6.23.1-49.fc8.x86_64 dmesg
Comment 14 Tomasz Kepczynski 2007-11-18 06:07:30 EST
Created attachment 262811 [details]
kernel-2.6.23.1-49.fc8.x86_64 with noapic option dmesg
Comment 15 Tomasz Kepczynski 2007-11-18 06:07:56 EST
Created attachment 262821 [details]
kernel-xen-2.6.21-2950.fc8.x86_64 dmesg
Comment 16 Pedro Bezunartea 2007-12-18 21:57:13 EST
Same thing here...
AMD64
card 1: RTL-8169
card 2: VT6102 [Rhine-II]
kernel-2.6.23.1-42.fc8
Comment 17 Christopher Brown 2008-02-07 13:10:34 EST
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.
Comment 18 Tomasz Kepczynski 2008-02-13 13:33:55 EST
This problem seems to be gone in
kernel-2.6.23.15-137.fc8.x86_64
Comment 19 Christopher Brown 2008-02-13 15:55:16 EST
Thanks Tomasz. Would be good to get feedback from the original reporter as well.
Huub?
Comment 20 Huub 2008-02-14 07:18:12 EST
It indeed seems that the latest kernel doesn't have the problem anymore.

Note You need to log in before you can comment on or make changes to this bug.