Bug 377511 - TOC ignores Headings with numbering on
Summary: TOC ignores Headings with numbering on
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
(Show other bugs)
Version: 8
Hardware: All Linux
high
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-12 10:53 UTC by Peter Vrabec
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-12 15:14:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
example (7.22 KB, application/vnd.oasis.opendocument.text)
2007-11-12 15:03 UTC, Peter Vrabec
no flags Details
fixed document (7.49 KB, application/vnd.oasis.opendocument.text)
2007-11-12 15:13 UTC, Caolan McNamara
no flags Details
that's what I see (85.98 KB, image/png)
2007-11-12 15:27 UTC, Peter Vrabec
no flags Details

Description Peter Vrabec 2007-11-12 10:53:49 UTC
Version-Release number of selected component (if applicable):
openoofice.org-{2.1,2.2,2.3}

How reproducible:
1. create table of content
2. create some headings
3. set numbering style on these headings
4. update table of content

Actual results:
c that headings are missing in TOC

Expected results:
TOC should contain all headings

Comment 1 Caolan McNamara 2007-11-12 11:36:33 UTC
Really ?, works fine for me. Can you attach an example of a document where it is
not working.

Comment 2 Peter Vrabec 2007-11-12 15:03:00 UTC
Created attachment 255301 [details]
example

Comment 3 Caolan McNamara 2007-11-12 15:12:29 UTC
right clicking in the toc I see that, as normal, the toc is generated from
"outline" and "index marks", checking under "tools outline->numbering" I see
that Level 1 is "none", and "Heading 1" does not appear under any level, so
that's why it is not considered for putting into the TOC. The default situation
is that Heading 1 is in that list so it has been moved away from the defaults. 

Attached is the same doc with your outline numbering fixed, alternatively you
could use "additional styles" in the TOC to add Heading 1 in there as well, but
that's an unusual way to do it generally.

Comment 4 Caolan McNamara 2007-11-12 15:13:23 UTC
Created attachment 255321 [details]
fixed document

Comment 5 Peter Vrabec 2007-11-12 15:27:49 UTC
Created attachment 255331 [details]
that's what I see

Comment 6 Peter Vrabec 2007-11-12 15:31:17 UTC
(In reply to comment #3)
> right clicking in the toc I see that, as normal, the toc is generated from
> "outline" and "index marks", checking under "tools outline->numbering" I see
> that Level 1 is "none", and "Heading 1" does not appear under any level, so
> that's why it is not considered for putting into the TOC. 
Sure.

> The default situation
> is that Heading 1 is in that list so it has been moved away from the 
defaults. 
How? I didn't do it.

> Attached is the same doc with your outline numbering fixed, ...
c my screenshot



Comment 7 Caolan McNamara 2007-11-12 15:36:37 UTC
Please look at your tools->outline numbering->numbering dialog.

Comment 8 Peter Vrabec 2007-11-13 10:49:45 UTC
OK, I can use numbering dialog in outline numbering and than update the TOC. 
But can you explain why, heading with numbering style is problem for TOC? 
Because this sounds like a bug to me? It used to work fine in oo-1.0.4.

Comment 9 Caolan McNamara 2007-11-13 11:02:22 UTC
Section 7.7 of http://specs.openoffice.org/writer/numbering/NumberingBullet1.sxw

"The following exceptions exist (but did not exist in OO.org 1.1):
If a paragraph has a numbering/bullet assigned, it will not be counted in the
chapter numbering"

So that the default OOo numbering mechanism is exportable to msoffice.

Comment 10 Peter Vrabec 2007-11-13 13:15:07 UTC
fine, I understand to it now, thnx. :-)


Note You need to log in before you can comment on or make changes to this bug.