Bug 377681 - Broken link means it fails to launch from icon
Broken link means it fails to launch from icon
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: stellarium (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Jochen Schmitt
Fedora Extras Quality Assurance
:
: 352251 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-12 08:04 EST by Ian Chapman
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.9.0-6.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-20 12:48:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the outputt of 'lsmod' (3.06 KB, application/octet-stream)
2007-11-19 15:47 EST, Mariusz Wodzicki
no flags Details

  None (edit)
Description Ian Chapman 2007-11-12 08:04:02 EST
Description of problem:

stellarium-wrapper is called from the .desktop icon which is in turn a BROKEN
symlink to opengl-game-wrapper

It should be a symlink to opengl-game-wrapper.sh


Version-Release number of selected component (if applicable):
stellarium-0.9.0-5.fc8

How reproducible:


Steps to Reproduce:
1. Run it from the menu.
2.
3.
  
Actual results:

It doesn't run.


Expected results:

It should run.

Additional info:
Comment 1 Jochen Schmitt 2007-11-15 11:37:26 EST
I have initiate an update of stellarium-0.9.0-6.fc8 on bodhi.
Comment 2 Fedora Update System 2007-11-15 19:42:19 EST
stellarium-0.9.0-6.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update stellarium'
Comment 3 Mariusz Wodzicki 2007-11-16 23:12:34 EST
Having experienced the same problem with stellarium-0.9.0-5.fc8 as in the
original bug report, I updated it to stellarium-0.9.0-6.fc8 from
updates-testing, following Johen Scmitt's suggestion, see Comment #2.

Now, when I start stellarium from the menu a window pops up and quickly
disappers. When I execute stellarium from the command line, here is what I get:

$ stellarium
 -------------------------------------------------------
[ This is Stellarium 0.9.0 - http://www.stellarium.org ]
[ Copyright (C) 2000-2006 Fabien Chereau et al         ]
 -------------------------------------------------------
File search path set to:
 1) /home/wodzicki/.stellarium
 2) /usr/share/stellarium
config file is: /home/wodzicki/.stellarium/config.ini
Xlib:  extension "ATIFGLRXDRI" missing on display ":0.0".
QGLContext::makeCurrent(): Cannot make invalid context current.
QGLContext::makeCurrent(): Cannot make invalid context current.
ERROR when trying to locate icon file: file not found: data/icon.bmp
terminate called after throwing an instance of 'std::logic_error'
  what():  basic_string::_S_construct NULL not valid
Abort
Comment 4 Jochen Schmitt 2007-11-18 14:51:09 EST
Hello, can you can tell me which X driver do you use.

As a second question, it may be helpful, if you can check, if the package
qt4-x11 is installed on your system.
Comment 5 Jochen Schmitt 2007-11-19 14:31:30 EST
*** Bug 352251 has been marked as a duplicate of this bug. ***
Comment 6 Mariusz Wodzicki 2007-11-19 15:47:10 EST
Created attachment 263931 [details]
the outputt of 'lsmod'
Comment 7 antonio montagnani 2007-11-19 15:56:18 EST
I am surprised to see that in F9 stellarium calls for a 3D graphic adapter
otherwise it doesn't run.....I suppose that it should be reported under devel
list, but I guess that the two bugs are connected
Comment 8 Mariusz Wodzicki 2007-11-19 16:00:03 EST
Yes. the package qt4-x11 is installed on my system:

qt4-x11.i386   4.3.2-1.fc8   installed


I use 'radeon' driver (see the attached output of 'lsmod', Comment #6 above).

My laptop's smolt profile:

http://smolt.fedoraproject.org/show?UUID=8ffd91e4-2899-481e-ae79-8b21a176a571
Comment 9 Jochen Schmitt 2007-11-19 16:15:31 EST
I think, we have tow issues

1.) The broken link, which should be fixed in update-testing.

2.) The "ATIFGLRXDRI" missing issue. For this case it may be helpful to do a
"glxinfo | grep direct".  This may be caused by a wrong x.org configuration file
or wrong permissions on the device which is used for the DRI interface. But
because I don't have a ATI graphic adapter, I couldn't get support in this case.
The only thing I know, is the fact, that ATI have a poor OpenGL support.

Comment 10 antonio montagnani 2007-11-19 16:56:37 EST
I use a Nvidia card with a nv driver

and if I start from a terminal, it works....
Comment 11 Fedora Update System 2007-11-20 12:48:10 EST
stellarium-0.9.0-6.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.