Bug 377811 - sefault in uic
sefault in uic
Status: CLOSED DUPLICATE of bug 377931
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
8
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-12 09:28 EST by Neal Becker
Modified: 2008-05-05 22:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-12 10:35:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neal Becker 2007-11-12 09:28:32 EST
Description of problem:

rpm -qf /usr/lib64/qt-3.3/bin/uic
qt-devel-3.3.8-9.fc8.x86_64

/usr/lib64/qt-3.3/bin/uic -L /usr/lib64/kde3/plugins/designer -nounload -impl 
actest.h actest.ui
segfault

gdb says:
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 46912496384624 (LWP 22011)]
0x000000383d4118ad in __cxa_pure_virtual () from /lib64/libselinux.so.1
(gdb) where
#0  0x000000383d4118ad in __cxa_pure_virtual () from /lib64/libselinux.so.1
#1  0x000000383d404d2f in __cxa_pure_virtual () from /lib64/libselinux.so.1
#2  0x0000003833c1b000 in ?? () from /lib64/ld-linux-x86-64.so.2
#3  0x0000000000000000 in ?? ()

I _don't_ think this has anything to do with selinux (which is disabled), I 
think it's a destructor issue.

valgrind says:

==22199== Invalid read of size 8
==22199==    at 0x383D4118AD: (within /lib64/libselinux.so.1)
==22199==    by 0x383D404D2E: (within /lib64/libselinux.so.1)
==22199==    by 0x383D412F60: (within /lib64/libselinux.so.1)
==22199==    by 0x3834C34028: exit (in /lib64/libc-2.7.so)
==22199==    by 0x3834C1E07A: (below main) (in /lib64/libc-2.7.so)
==22199==  Address 0x78 is not stack'd, malloc'd or (recently) free'd
==22199== 
==22199== Process terminating with default action of signal 11 (SIGSEGV)
==22199==  Access not within mapped region at address 0x78
==22199==    at 0x383D4118AD: (within /lib64/libselinux.so.1)
==22199==    by 0x383D404D2E: (within /lib64/libselinux.so.1)
==22199==    by 0x383D412F60: (within /lib64/libselinux.so.1)
==22199==    by 0x3834C34028: exit (in /lib64/libc-2.7.so)
==22199==    by 0x3834C1E07A: (below main) (in /lib64/libc-2.7.so)
==22199== 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Neal Becker 2007-11-12 10:35:00 EST
Found!  Problem was caused by 
usr/lib64/qt-3.3/plugins/designer/libQVTKWidgetPlugin.so
vtk-qt-5.0.3-20.fc8.x86_64
Comment 2 Galen A. 2008-05-05 22:55:40 EDT

*** This bug has been marked as a duplicate of 377931 ***

Note You need to log in before you can comment on or make changes to this bug.