Bug 377991 - Compiz refuses to activate
Compiz refuses to activate
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
8
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-12 10:39 EST by Philip Ashmore
Modified: 2008-01-31 10:22 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-31 10:22:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philip Ashmore 2007-11-12 10:39:54 EST
Description of problem:
kde-desktop-effects.sh fails to enable desktop effects

Version-Release number of selected component (if applicable):
compiz-0.6.2-3.fc8.rpm

How reproducible:
very

Steps to Reproduce:
1. In a konsole window, at the prompt, denoted by [$], type kde-desktop-effects.sh
2. The "Desktop Effects" dialog is displayed
3. Select "Enabled (Use Compiz)"
4. Click on the "OK" button
5. 
  
Actual results:
[$] kde-desktop-effects.sh
Using compiz-manager as window manager
Checking for Xgl: not present.
Detected PCI ID for VGA: 01:00.0 0300: 10de:0112 (rev b2) (prog-if 00 [VGA])
        Flags: bus master, VGA palette snoop, 66MHz, medium devsel, latency 248,
IRQ 11
Checking for texture_from_pixmap: Desktop Effects could not be enabled.
[$] present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Comparing resolution (1600x1200) to maximum 3D texture size (2048): Passed.
Checking for nVidia: present.
Less than 65536kb of memory and nVidiaaborting and using fallback: /usr/bin/kwin
[$]

Expected results:
Desktop effects enabled.

Additional info:
My smolt data is at
    http://smolt.fedoraproject.org/show?UUID=780f4114-ba22-4875-ab6a-34113ae3fb75

This worked (albeit with some tweaking) on Fedora 7 with Xgl.
Comment 1 vvs 2007-11-14 07:09:37 EST
What graphics driver do you use? You have a NVIDIA card and Fedora have two
drivers for it: nv and nouveau. The nv driver does not have 3D acceleration at
all, so what do you expect? The nouveau driver is experimental and I don't have
much experience with it, so if it doesn't work I'm afraid you have to install
closed source NVIDIA driver from www.nvidia.com.
Comment 2 Philip Ashmore 2007-11-17 13:44:01 EST
Did you see "Checking for nVidia: present." above?

I'm using the closed source nvidia driver
# rpm -qa|grep nvidia
    kmod-nvidia-96xx-2.6.23.1-49.fc8-96.43.01-17.lvn8
    kmod-nvidia-96xx-96.43.01-17.lvn8
    xorg-x11-drv-nvidia-96xx-96.43.01-3.lvn8.1

# kde-desktop-effects.sh
kbuildsycoca running...
Reusing existing ksycoca
Using compiz-manager as window manager
Checking for Xgl: not present.
Detected PCI ID for VGA: 01:00.0 0300: 10de:0112 (rev b2) (prog-if 00 [VGA])
        Flags: bus master, VGA palette snoop, 66MHz, medium devsel, latency 248,
IRQ 11
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Comparing resolution (1600x1200) to maximum 3D texture size (2048): Passed.
Checking for nVidia: present.
Less than 65536kb of memory and nVidiaaborting and using fallback: /usr/bin/metacity
Desktop Effects could not be enabled.

It looks like it's insisting on 64MB of on-board nvidia graphics memory.
My nvidia Geforce 2GO has 32MB on-board memory.
My laptop has 256MB system memory.
I found the Xgl version to be buggy/incomplete, but I fondly remember that half
hour, before I started tweaking it, when it worked.
By tweaking it I mean using the supplied GUI interfaces.
Comment 3 Philip Ashmore 2007-12-10 16:44:52 EST
With the recent batch of updates Compiz now starts, but sometimes the windows
and menus exhibit the "black window" problem I saw mentioned while trawling the web.

I've started brushing up on OpenGL and I would hazard a guess that Compiz is
using OpenGL "display lists" in an attempt to increase performance by using the
graphics cards video memory. Fine if you've got lots of video memory.

The down side is that with Compiz/Emerald some windows are black and others, like
 * gnome-system-log
 * thunderbird
 * firefox
 * menus
don't appear to respond at all.
The menus do work even though their appearance doesn't change.
The window decorations (minimize/maximize etc) aren't always visible when they
should be, although you can see the tooltips and they work.

Switching back to the KWin window manager using fusion-icon I could tell that
the apps really were responding - you just couldn't see it.

While I'm at it, installing fusion-icon was troublesome.
I'm not an RPM expert, but I seem to recall (maybe it was Debian) that packages
could indicate that they required facilities that could be provided by more than
one package.
That being the case, fusion-icon should indicate that it requires facilities
provided by
 * emerald or similar window decorator
 * fusion-icon-gnome or fusion-icon-qt - maybe both, depending on the window
manager you're using
Comment 4 Matěj Cepl 2008-01-31 10:22:13 EST
Thanks for the report. We are sorry that we cannot help you with your problem,
but we are not able to support binary-only drivers. If you would be able to
reproduce this issue using only open source software, please, reopen this bug
with the additional information, but in meantime I have no choice than to close
this bug as CANTFIX (because we really cannot fix it).

For users who are experiencing problems installing, configuring, or using the
unsupported 3rd party proprietary "nvidia" video driver, Nvidia provides
indirect customer support via an online web based support forum.  Nvidia
monitors these web forums for commonly reported problems and passes them on to
Nvidia engineers for investigation.  Once they've isolated a particular problem,
it is often fixed in a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

    http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums, others who may have
experienced the particular problem may be able to assist.  If there is a real
bug occuring, Nvidia will be able to determine this, and will likely resolve the
issue in a future driver update for the operating system releases that they
officially support.

While Red Hat does not support the proprietary nvidia driver, users requiring
technical support may also find the various X.Org, XFree86, and Red Hat mailing
lists helpful in finding assistance:

X.Org mailing lists:
    http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
    http://www.xfree86.org/sos/lists.html

Red Hat mailing lists:
    https://listman.redhat.com/mailman/listinfo

Note You need to log in before you can comment on or make changes to this bug.