Bug 378001 - Firefox doesn't have any functionality at all!
Firefox doesn't have any functionality at all!
Status: CLOSED DUPLICATE of bug 386051
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
8
All Linux
low Severity urgent
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-12 10:47 EST by sean.mcguffee
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-19 09:40:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sean.mcguffee 2007-11-12 10:47:23 EST
Description of problem:

(1) plugin application/x-shockwave-flash not automatically installed
not to mention, it doesn't install automatically when you try to install it.

(2) google toolbar bookmarks quit working even though they worked in Fedora 7.
not to mention, the google toolbar wasn't automatically installed.

(3) JavaScript is not enabled nor does it appear to be there.

(4) Adobe acrobat reader does not automatically open PDF files when browsing the
internet. It's not even clear to me that Adobe acrobat reader is even on this
machine. How can you call yourself a web browser if you cannot even open the
main file that is found on the web? In case you don't realize, almost all
journals are published online in PDF format. 

Come on! These are the sort of things that should have be installed
automatically! Because it takes over a day to install Fedora 8, there are no
excuses! There should be no further installations required. Not to mention,
these things should be easy and automatic to install--not labor and research
intensive. Get with the program! 

Version-Release number of selected component (if applicable):


How reproducible:

Every time

Steps to Reproduce:
1. start web browser
2. try to use it for PDF's, Google Toolbar's Bookmarks, or for aol or yahoo
games like chess.
3.
  
Actual results:

this browser is not complete and functionality is not there.

Expected results:

I expect my browser to work from the beginning on every single page I go to. I
especially expect it to automatically open PDF files with adobe acrobat reader,
to automatically have google toolbar installed and for the bookmarks to work
when installed, and to be able to play chess on aol or yahoo without special
installation of additional software. 

Additional info:
Comment 1 Matěj Cepl 2007-11-12 11:41:26 EST
1) we cannot ship proprietary software (that includes flash-plugin, adobe
acrobat reader, and google toolbar)
2) you can read PDF perfectly well with evince, which should be the program run
automatically when clicking on PDF link.
3) Javascript is certainly on and working.

I suspect that you have something strange in your ~/.mozilla profile. Could you
please move it somewhere else (e.g., rename it to ~/_mozilla-save) and
restarting firefox. Does Javascript work then?
Comment 2 Matěj Cepl 2007-11-12 11:41:47 EST
(and of PDF should be opened in Evince as well)
Comment 3 sean.mcguffee 2007-11-14 08:50:56 EST
Let me see if I get this right? You and I can both freely download flash-plugin,
adobe acrobat reader, and google toolbar, but you aren't allowed to let me
download it from you after you download it? Why don't you just do it and let
them try to sue you? You can always just take a video of it being free for
anyone to take to court if you really think it would got there. That way you
could prove that they didn't lose any money by you doing it.

You were right about firefox having the recommended Java installed (1.7.0)
according to the java test page. However, you were also wrong because this is
what happens when I try to use java in firefox at aol's chess site:

"
The following error has occurred:
Java Not Found or Not Working

Explanation:
This error means Java (one of the technologies built into most browsers) is not
working correctly on your browser.

You must have Java installed on your computer in order to run Pogo games, and it
must be functioning properly. Either you don't have Java installed yet, or the
Web browser you're currently using doesn't support Java or you have Java (or
Javascript) disabled in your browser.

How to Fix the Problem:
Java is a free download that is required to play Pogo games. Not all computers
come with Java pre-installed.

If you haven't played Pogo games before and are getting this error, you probably
just need to install Java on your computer.
For instructions on installing Java for your operating system and browser click
here.

If you believe Java might be installed but disabled for your browser, please be
sure to enable the plugin for your browser. If you need help, click here.

If you already have Java installed and it is not disabled, your Java may be
out-of-date or is no longer working. In that case, your Java might need to be
upgraded or reinstalled. If you need help, click here.
"

on http://game1.pogo.com/error/java-problem.jsp?site=aolc

while trying to load a chess game from:
http://aolcom.pogo.com/games/chess?gamekey=chess&returnType=game&returnValue=chess2&nlruser=true

It says java is installed when I try the site:
http://www.java.com/en/download/installed.jsp, but then it doesn't function as I
just illustrated.

However, I can't get google toolbar's bookmarks to work on firefox, so it
doesn't really do any good to have java on a web browser that I can't use with
my bookmarks. I am now trying to get java to work on netscape navigator. I can
get google toolbar to function completely on netscape, but not on firefox.
Anyway, I guess it would be best to get both working correctly, right? I tried
taking the plugins that I used to use on FC7 and putting them in my
/usr/navigator/plugin directory (they were from a java i386 download). I also
tried just now taking the java plugin listed in the new
.mozilla/firefox/pluginreg.dat file (since it's working on mozilla firefox by
the test site if not on the real usage site). However, it still gave me the
message at the top of the screen that I needed a plugin to see the page
properly. I've tried a lot of things. I have gotten three types of results. The
main result is that no plugin is recognized and netscape tells me that a plugin
is required. The other two responces have been either a shudown of the browser
upon testing or a lack of any response upon testing. I tried the
http://www.java.com/en/download/installed.jsp page finally to help speed up the
testing process, but I guess that isn't sufficient. Anyway, could you help me
get netscape to use java? It's the newest navigator I'm using. By the way, I
tried to use the nspluginwrapper thing to get java to work on netscape, but it
gave me errors about the java plugins not being the right type of plugins for it
to work. It did work for the flashplayer though. I'm not sure if that's the way
you were recommending because I figured that out before I got your email. I do
have vague memory that was how I installed java in FC7 though. Thus, I might
have a problem if that method won't work. I just think it would be better for
people to figure this stuff out, make a button that does it, and then distribute
FC8 instead of having everyone figure it out after the distribution. Or at least
once it's figured out they could make a download patch that automatically fixes
it. There are a lot of man hours being wasted this way that could be used to
improve the software after it's working, you know? Maybe we could sue the
proprietary companies for not letting you distribute things in a way that
work--that would be a legitimate case because a lot of harm is being done here
by suddenly not having a system that functions at all by trying to upgrade. I've
wasted a total of 76 hours of straight doing nothing but trying to get my
computer to work again. I'm completely unable to do any work without a
functional computer. Old versions of fedora are so nonfunctional because of
being incomplete that I have to at least try to upgrade. I just wish the main
stuff would work, you know? I wish they would just upgrade by adding new things
and not messing with the stuff that does work already.

By the way, firefox prevents me from doing things without holding control down
(you know what I'm talking about with popups or whatever?). However, the button
that should let me change that to avoid the annoying inconvenience doesn't work.
Honestly, if anyone is stupid enough to want or need one of those type of
things, then let them screw up their machine. Obviously they are using their
computer for porn. Please think about who you are designing your software for.
If anyone has a reasonable use of their computer, they don't need porn
protection. Thus, why don't you allow regular users to use their computer
regularly without screwing it up with needing control keys held down constantly?
Why not just let the porn man have his own trouble. He's gonna have trouble if
he's that into porn anyway, right? In other words (in case you can't understand
my rhetoric), please take the control key popup protection off, not to mention
get the button to let me take it off.

By the way, the PDF thing worked out alright. Somehow that plugin worked great
from the button install method. I never could get that to work on FC7. Assuming
google toolbar ever gets fixed on firefox, there are only about three reasons
left regarding why I still turn to windows under necessity. First, I like to use
dictation software, and I found some really good stuff that is designed to work
on a windows machine. Second, I like to use webcams sometimes on instant
messengers, although not lately. But, you know, like yahoo IM didn't have a
webcam feature on here last time I checked on here. Third, I'm kinda into the
brand names of software like office, and endnote. However, that's changing. I
think I'm getting close to switching over completely. At this point, the openGL
stuff brings me to linux by necessity. I certainly can't find any way to program
in C on windows. I might be possible, but I don't count on my programs being
transferable to the next windows version. Do you know of a way to run software
for windows while in linux? Is there a freeware way to do that?

Thanks for your valuable help,

Sean =)
Comment 4 Zoltán Magyar 2007-11-18 11:21:50 EST
Hello!

Here are two links, that provide instructions on how to install flash, wine and
a lot of other things for fedora:
http://www.fedorafaq.org/
http://www.mjmwired.net/resources/mjm-fedora-f8.html

If I understand you correctly, you want to disable the pop-up blocking in firefox?
You can do this by going to Edit -> Preferences -> Content and uncheck the
"Block pop-up windows" option.
Comment 5 Zoltán Magyar 2007-11-18 11:22:49 EST
I'm sorry, I forgot to mention, that wine can be used to run windows programs on
linux.
Comment 6 Matěj Cepl 2007-11-19 09:38:08 EST
(In reply to comment #3)
> Why don't you just do it and let them try to sue you?

Won't happen. Ever. Period. Don't even waste your time asking (Red Hat being an
American coproration won't make itself into moving target for litigation).

> You were right about firefox having the recommended Java installed (1.7.0)
> according to the java test page. However, you were also wrong because this is
> what happens when I try to use java in firefox at aol's chess site:

Please, don't confuse JavaScript and Java -- they have absolutely nothing in
common (marketing guy in Netscape who invented the name JavaScript because Java
was hot then should be burned in hell).

> It says java is installed when I try the site:
> http://www.java.com/en/download/installed.jsp, but then it doesn't function
> as I just illustrated.

Which indicates to me, that AOL Pogo chess is broken. I have tried to run the
same page here (I have IcedTea OpenJDK installed) and firefox crashed. Whatever
it is they are doing, it doesn't seem to be right IMHO.

> However, I can't get google toolbar's bookmarks to work on firefox,

Do you have 64bit Linux installed by chance -- then this would be duplicate of
bug 386051, which should be closed in my opinion.

> I am now trying to get java to work on netscape navigator.

Note, that Netscape Navigator is not Firefox, we don't have source code for it,
and it is most likely that AOL put patched it so that it works with AOL website
and Google. If it works, don't come to us to tell, that we should fix Firefox
accordingly. We have no idea what they did to it to make it work.

> tried to use the nspluginwrapper thing to get java to work on netscape,

nspluginwrapper from Fedora probably doesn't work for Netscape. Not sure about
that though.

> Do you know of a way to run software for windows while in linux?

wine is able to run some Windows programs on Linux, but no guarantees about that
(and I have no idea whether wine works for x86_64 at all). There are also some
proprietary software enabling most common Windows programs on Linux.

So, after making myself ugly by not providing flash, etc., what is there
remaining in this bug which would be our issue?
Comment 7 Matěj Cepl 2007-11-19 09:40:49 EST
Sorry, I only recognized that this is actually duplicate of bug 386051 from the
same reporter.

*** This bug has been marked as a duplicate of 386051 ***

Note You need to log in before you can comment on or make changes to this bug.