Bug 378301 - yum repos don't point to ppc64 update/debuginfo files
Summary: yum repos don't point to ppc64 update/debuginfo files
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-release   
(Show other bugs)
Version: 8
Hardware: powerpc
OS: Linux
low
low
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-12 17:06 UTC by Frank Ch. Eigler
Modified: 2013-01-10 01:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-16 14:29:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Frank Ch. Eigler 2007-11-12 17:06:12 UTC
With a fedora8-equipped PS3, yum does not appear to see some ppc64 updates
in yum check-update.  It is as if the fedora-update*repo files refer to URLs
that exclude some of the needed files.  Specifically, kernel-debuginfo.

Adding a new "ppc64"-flavoured, baseurl-only clause to the yum repo file,
this works.

Comment 1 Jesse Keating 2007-11-15 19:56:15 UTC
This is going to be extremely difficult to resolve cleanly.  David, I'm up for
suggestions..

Comment 2 Frank Ch. Eigler 2007-11-16 12:49:17 UTC
Why can't the solution used for x86-64 work here?  That is, having a combined
ppc64/ppc updates/ directory?

Comment 3 Jesse Keating 2007-11-16 14:29:34 UTC
Because there is no kernel-debuginfo.i386 in the x86_64 repo, so it isn't
actually fixed there.

We may be able to fix it later with other multilib changes being discussed today.

http://fedoraproject.org/wiki/BillNottingham/MultilibDraft

Comment 4 Frank Ch. Eigler 2007-11-16 15:30:33 UTC
(In reply to comment #3)
> Because there is no kernel-debuginfo.i386 in the x86_64 repo, so it isn't
> actually fixed there.

But I'm not looking for the analogous kernel-debuginfo.ppc, just the .ppc64 -
the same situation as for x86-64.

> We may be able to fix it later with other multilib changes being discussed today.
> 
> http://fedoraproject.org/wiki/BillNottingham/MultilibDraft

OK, looking forward to it.

Comment 5 David Woodhouse 2007-11-16 15:42:21 UTC
No, kernel-debuginfo.ppc64 _is_ analogous to kernel-debuginfo.i386. On PPC64 we
favour ppc32 packages and ppc64 is the 'secondary' architecture. On x86_64 we
favour x86_64 packages and i386 is the 'secondary' architecture.

One of Bill's improvements to the plan laid out in the multilib tracker bug
(#235752) is the suggestion that x86_64 machines wishing to install i386 stuff
could just use the _normal_ i386 repository, rather than having the packages
appear in any x86_64-specific repository. If we make the tools cope with those
extra packages properly (i.e. not _installing_ them all just because they're
there), that seems like it would be the right thing to do. And would address
this problem too.

https://bugzilla.redhat.com/showdependencytree.cgi?id=multilib


Note You need to log in before you can comment on or make changes to this bug.