Bug 378321 - Regression: Dell D820 fails to boot with kernel 2.6.23.1-49
Regression: Dell D820 fails to boot with kernel 2.6.23.1-49
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-12 12:16 EST by Emmanuel Kowalski
Modified: 2007-12-04 01:43 EST (History)
1 user (show)

See Also:
Fixed In Version: kernel-2.6.23.8-63.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-04 01:43:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Digital picture of failed boot (502.64 KB, image/jpeg)
2007-11-14 16:38 EST, Emmanuel Kowalski
no flags Details
Messages from working kernel (2.35 KB, text/plain)
2007-11-14 16:39 EST, Emmanuel Kowalski
no flags Details

  None (edit)
Description Emmanuel Kowalski 2007-11-12 12:16:33 EST
Description of problem:
After updating the kernel to 2.6.23.1-49, my Dell D820 laptop does not boot
with the new kernel. It works fine with previous one 2.6.23.1-42.


Version-Release number of selected component (if applicable):
kernel-2.6.23.1-49.fc8


How reproducible:
Always

Steps to Reproduce:
1. Try to boot with kernel-2.6.23.1-49
2.
3.
  
Actual results:
Boot fails (hangs after displaying "OK, Booting the kernel")

Expected results:
Boot continues...

Additional info:
I haven't tried any boot option since the previous version works.
Comment 1 David Wood 2007-11-14 04:31:52 EST
My HP nx9010 doesn't boot with kernel-2.6.23.1-49 either.  I'm getting an
endless string of segfault's after the init message.  Version -42 was (is) fine.
Comment 2 Chuck Ebbert 2007-11-14 14:11:36 EST
(In reply to comment #0)
> Description of problem:
> After updating the kernel to 2.6.23.1-49, my Dell D820 laptop does not boot
> with the new kernel. It works fine with previous one 2.6.23.1-42.
> 
> 
> Version-Release number of selected component (if applicable):
> kernel-2.6.23.1-49.fc8
> 
> 
> How reproducible:
> Always
> 
> Steps to Reproduce:
> 1. Try to boot with kernel-2.6.23.1-49
> 2.
> 3.
>   
> Actual results:
> Boot fails (hangs after displaying "OK, Booting the kernel")
> 

Remove the "quiet" option from the entry in /etc/grub.conf for the new kernel
and boot it to see what messages if any it prints before stopping.
Comment 3 Emmanuel Kowalski 2007-11-14 16:38:15 EST
I removed the quiet option, and the boot stopped just after the line
"Serial: 8250/16550 driver... IRQ sharing enabled"

I will attach a digital picture of the boot, and separately a text file with
the corresponding portion of the messages during a boot with 2.6.23.1-42.

Comment 4 Emmanuel Kowalski 2007-11-14 16:38:59 EST
Created attachment 258931 [details]
Digital picture of failed boot
Comment 5 Emmanuel Kowalski 2007-11-14 16:39:37 EST
Created attachment 258941 [details]
Messages from working kernel
Comment 6 Chuck Ebbert 2007-11-14 17:18:42 EST
Does adding the option "serial.nr_uarts=0" make any difference?
Comment 7 Emmanuel Kowalski 2007-11-15 01:41:05 EST
I tried serial.nr_uarts=0 which didn't do any thing.
Since Google didn't find any reference for this option, but mentioned
8250.nr_uarts=0, I tried that too.  This helped go a bit further in the boot
(three or your more messages onscreen, up to

Yenta O2: enabling read prefetch/write burst

then it hanged as before.

Comment 8 Emmanuel Kowalski 2007-12-04 01:43:54 EST
The bug seems to be fixed in the new kernel

kernel-2.6.23.8-63.fc8

Note You need to log in before you can comment on or make changes to this bug.