Bug 378611 - Missing fedora-8-gold, f8 config files
Missing fedora-8-gold, f8 config files
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: revisor (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-12 14:23 EST by Jonathan S. Shapiro
Modified: 2008-02-18 19:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-18 19:10:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonathan S. Shapiro 2007-11-12 14:23:29 EST
Probably on all platforms.

I ran into a bug with the livecd that has since been fixed in kernel. This led
me to try a respin which led me to discover that the necessary revisor support
to accomplish the respin doesn't exist yet.

Being intrepid, I went and grabbed the in-progress versions from the git repo.
This in turn led me to discover some bugs in the *production* comps file; there
are mandatory packages iprutils and yaboot that are present in the SRPMS tree
but are missing in the binary RPM tree on both the publicly served tree and the
installation media.

I want to suggest two things here:

1. Getting those config files out should be high priority because the livecd is
broken; there is a piix SATA problem that also existed in F7 and (judging by
google) is being seen all over as people try to install on current core2duo
laptops. I see that the needed update is in koji. Not clear if it's done, but if
it is it would be good to fast-track it.

2. In future, Fedora should not go to release until it has been confirmed that
the initial release can be successfully respun. This would have caught the
missing packages, and therefore serves as a useful QA validation. It also
ensures that people can rev their way out of any errors that may ship with the
initial release.
Comment 1 Jeroen van Meeuwen 2007-11-12 15:46:39 EST
The missing configuration files are released with revisor-2.0.5-7, pending to be
pushed to updates/ (https://admin.fedoraproject.org/updates/F8/FEDORA-2007-2960)
Comment 2 Jonathan S. Shapiro 2007-11-12 15:53:52 EST
Great. There was something else -- let me know if you want me to file another bug.

I had grabbed those files from git and tried them. Ran into two problems:

1. revisor incorrectly complains that packages are missing when they aren't. The
packages in question are designated mandatory in the comps file but are not
applicable to the i386 target. Possibly revisor isn't doing the target
architecture check, or isn't doing it right.

2. building a respin live-dvd with --live-optical, complaining of lack of space
on loop-mounted target ISO fs.

Since I was kludging about, item [2] may well be my fault, and I will retry when
the RPM update gets out. Item [1] seems like a bug. Want a separate report?
Comment 3 Jonathan S. Shapiro 2007-11-12 15:54:52 EST
In connection with the target architecture issue, see dcantrell's comments in

https://bugzilla.redhat.com/show_bug.cgi?id=378591
Comment 4 Jeroen van Meeuwen 2008-02-18 19:10:23 EST
Revisor complaints correctly about the packages missing. These packages are in
comps.xml as mandatory or default packages but are not available in the
repositories. Revisor will need to complain about these packages missing because
they have been selected in kickstart, via groups or directly.

Revisor 2.1.0 will not warn about packages missing from the @core group though:

http://git.fedorahosted.org/git/?p=revisor;a=commitdiff;h=ab17bfb19b80c62474910077dd95cdbe9317ccd8

Note You need to log in before you can comment on or make changes to this bug.