Bug 379261 - gnome-appearance-properties segfaults (during theme thumbnailing?)
gnome-appearance-properties segfaults (during theme thumbnailing?)
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: librsvg2 (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-12 20:52 EST by Corey Welton
Modified: 2007-12-10 10:15 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-10 10:15:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of segfault which plagues my gnome-appearance-properties (4.14 KB, text/plain)
2007-11-12 20:55 EST, Corey Welton
no flags Details
gnome-appearance-properties_backtrace-full.txt (5.38 KB, text/plain)
2007-11-13 21:55 EST, Corey Welton
no flags Details
gnome-appearance-properties_trace-valgrind.txt (29.31 KB, text/plain)
2007-11-13 21:55 EST, Corey Welton
no flags Details

  None (edit)
Description Corey Welton 2007-11-12 20:52:50 EST
Description of problem:
I'd been running XFce for some time, when I decided to upgrade from F7 -> F8
(versus fresh install).  I did so, and after hearing all the great new features
added to Gnome in F8, I thought I'd give it a shot again.

I ran `yum groupinstall "GNOME Desktop Environment"`, switched my desktop to
GNOME, and started X.  Upon starting X, first thing I wanted to do was change
the look and feel a bit... however, running `gnome-appearance-properties` causes
a segfault every time I try to run it.

Version-Release number of selected component (if applicable):
 control-center-2.20.1-5.fc8

How reproducible:
 Every time

Steps to Reproduce:
1.  Start Gnome
2.  from shell, or from GNOME menu, run "gnome-appearance-properties"
3.  Observe
  
Actual results:
 Segfault

Expected results:
 Functioning program

Additional info:

*  After attempting to wipe all all traces of .gnome-ish config files in ~/, in
hopes that this would fix the glitch, I later noted that this occurs with both
root and non-root logins.

* Hardware is T43;  issue occurs regardless as to whether the video driver is
radeon or fglrx

* selinux is running in permissive mode

* Hints from halfline to include with the bug (although the issue seems to be
along a different path than initially thought):

[cwelton@ramen ~]$ ls -lZa /usr/share/gnome-background-properties
drwxr-xr-x  root root system_u:object_r:usr_t          .
drwxr-xr-x  root root system_u:object_r:usr_t          ..
-rw-r--r--  root root system_u:object_r:usr_t          desktop-backgrounds-basic.xml
-rw-r--r--  root root system_u:object_r:usr_t         
desktop-backgrounds-infinity.xml
-rw-r--r--  root root system_u:object_r:usr_t          gnome-branded.xml
-rw-r--r--  root root system_u:object_r:usr_t          gnome-nature.xml
-rw-r--r--  root root system_u:object_r:usr_t          gnome-tiles.xml
-rw-r--r--  root root system_u:object_r:usr_t          gnome-translucent.xml
-rw-rw-r--  root root system_u:object_r:usr_t          themes-backgrounds-gnome.xml

[cwelton@ramen ~]$ rpm -qf /etc/gnome-vfs-2.0/modules/* | sort -u
control-center-2.20.1-5.fc8
gnome-vfs2-2.20.0-3.fc8
gnome-vfs2-obexftp-0.4-2.fc8
gnome-vfs2-smb-2.20.0-3.fc8
nautilus-cd-burner-2.20.0-1.fc8

* I will attach what appears to be the appropriate portion of strace output for
this incident, although I can include the trace in its entirety, if so desired.
Comment 1 Corey Welton 2007-11-12 20:55:41 EST
Created attachment 256121 [details]
strace of segfault which plagues my gnome-appearance-properties
Comment 2 Bastien Nocera 2007-11-13 06:33:11 EST
Comment on attachment 256121 [details]
strace of segfault which plagues my gnome-appearance-properties

application/text doesn't exist as a mime-type...
Comment 3 Bastien Nocera 2007-11-13 06:34:13 EST
straces aren't useful to debug crashes. Could you please gather a backtrace
using gdb as per the instructions at:
http://fedoraproject.org/wiki/StackTraces
Comment 4 Corey Welton 2007-11-13 10:14:21 EST
Apologies for the bungled mimetype.

backtrace:

Thread 2 (Thread -1209141488 (LWP 15128)):
#0  0x05db279f in g_slice_alloc () from /lib/libglib-2.0.so.0
#1  0x05db7d33 in g_string_sized_new () from /lib/libglib-2.0.so.0
#2  0x05d9a3f5 in g_markup_escape_text () from /lib/libglib-2.0.so.0
#3  0x05d9af9d in g_markup_vprintf_escaped () from /lib/libglib-2.0.so.0
#4  0x05d9b06b in g_markup_printf_escaped () from /lib/libglib-2.0.so.0
#5  0x0805debc in gnome_wp_item_update_description (item=0x92dcd70)
    at gnome-wp-item.c:251
#6  0x080551e1 in wp_props_load_wallpaper (
    key=0x92dca58
"/usr/share/backgrounds/images/themes-backgrounds-gnome/GNOME-Dagg_1600x1200.jpg",
item=0x92dcd70, data=0x8f20ab0)
    at appearance-desktop.c:169
#7  0x05d88f16 in g_hash_table_foreach () from /lib/libglib-2.0.so.0
#8  0x080554be in wp_load_stuffs (user_data=0x8f20ab0)
    at appearance-desktop.c:868
#9  0x05d94491 in ?? () from /lib/libglib-2.0.so.0
#10 0x05d9605c in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#11 0x05d9949f in ?? () from /lib/libglib-2.0.so.0
#12 0x05d99849 in g_main_loop_run () from /lib/libglib-2.0.so.0
#13 0x063e7ae4 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#14 0x08058375 in main (argc=Cannot access memory at address 0x62f
) at appearance-main.c:190
Comment 5 Ray Strode [halfline] 2007-11-13 11:35:45 EST
hi,

Can you do 

(gdb) thread apply all bt full 

and post the output of that?

Does running

export G_SLICE=always-malloc

hide the crash?

With that environment variable set, can you run 

valgrind gnome-appearance-properties 

and see if it report anything interesting?
Comment 6 Corey Welton 2007-11-13 21:54:18 EST
>and post the output of that?
will attach.

>hide the crash?
Nope

> and see if it report anything interesting?
will attach.
Comment 7 Corey Welton 2007-11-13 21:55:04 EST
Created attachment 257611 [details]
gnome-appearance-properties_backtrace-full.txt
Comment 8 Corey Welton 2007-11-13 21:55:34 EST
Created attachment 257631 [details]
gnome-appearance-properties_trace-valgrind.txt
Comment 9 Corey Welton 2007-11-19 12:33:01 EST
Misread your second question above.  As it stands, it does appear that exporting
G_SLICE=always-malloc does hide the error -- or at least some other error text
that may or may not be related to this bug.  

When using "always-malloc", I get:

[cwelton@ramen ~]$ gnome-appearance-properties 

warning: Missing the separate debug info file:
/usr/lib/debug/.build-id/b8/15f4dcecb6010580bb2ebf9ad8412132353b71.debug
[...]

...whereas I get the following message w/o "always-malloc"

[cwelton@ramen ~]$ gnome-appearance-properties 
Error while mapping shared library sections:
: No such file or directory.

warning: Missing the separate debug info file:
/usr/lib/debug/.build-id/b8/15f4dcecb6010580bb2ebf9ad8412132353b71.debug

Comment 10 Corey Welton 2007-12-10 08:57:11 EST
Folks,

Playing with this some more, I think I resolved the issue -- at very least, i
fixed it on my end.

I noticed, while doing some debugging, that it kept crashing on one of the .svg
background files.  So I moved that file, and re-ran gnome-appearance-properties.
 This time, it crashed on a different .svg background.  I then moved all the
.svg files and re-ran again.

This time, the program did not crash - although I did notice svg-related context
in the terminal:

(gnome-appearance-properties:4471): Gtk-WARNING **: Error loading icon: Couldn't
recognize the image file format for file
'/usr/share/themes/Clearlooks_Cairo-Nuvola/gtk-2.0/icons/fileopen.svg'

At this point, I was fairly convinced something in the svg handling was at
fault.  So, in something of a banzai method, I reinstalled everything svg-related:

for i in `rpm -qa|grep svg`; do yes|smart reinstall $i; done

I then  moved the .svg background back, and things seem to work; I don't get the
aforementioned error message, either.

Not sure what the issue is/was here - Maybe it's more install/upgrade related,
since the packages seem to have not gotten installed cleanly or correctly.

Let me know if you want me to close the bug, or if you want to look into it some
more.


Comment 11 Ray Strode [halfline] 2007-12-10 10:15:15 EST
Hi,

I'm going to close this bug, since you've resolved this issue and no one else
has chimed in on the report as having reproduced.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.