Bug 379411 - [edd] installer hangs while booting
[edd] installer hangs while booting
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-11-13 00:56 EST by David Baron
Modified: 2008-06-11 22:19 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-06-11 22:19:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
/proc/cpuinfo for machine (1.19 KB, text/plain)
2007-11-13 00:59 EST, David Baron
no flags Details

  None (edit)
Description David Baron 2007-11-13 00:56:58 EST
Description of problem:  The Fedora 8 install DVD hangs while booting on my
x86_64 desktop machine.  I had the same problem with Fedora 7; I figured I'd
just leave it running Fedora Core 6 and hope the problem went away.  But the
Fedora Core 6 installer worked fine (although from CDs), as did the Fedora Core
5 test 3 installer.

How reproducible:  Always

Steps to Reproduce:
1. Boot from install DVD.
2. Chose "Install or upgrade an existing system (text)"
Actual results:
I see "Loading vmlinuz ...", "Loading initrd.img ...", and "Ready." on
successive lines (with lots of "..." omitted), and then the machine hangs (caps
lock and num lock don't change the keyboard's lights).

Expected results:
Installer boots.

Additional info:
At the suggestion of mharris64 on IRC, I tried booting with "nohz=off nolapic"
and with "nohz=off nolapic acpi=off" added to the kernel options.  That didn't
make a difference.
Comment 1 David Baron 2007-11-13 00:59:04 EST
Created attachment 256401 [details]
/proc/cpuinfo for machine
Comment 2 Chuck Ebbert 2007-11-13 14:17:12 EST
Try the workarounds:


Comment 3 David Baron 2007-11-14 23:53:44 EST
Using "edd=off" or "edd=skipmbr" makes the installer boot.
Comment 4 Chuck Ebbert 2007-11-15 16:03:58 EST
Is this a Dell system?
Comment 5 David Baron 2007-11-15 16:31:07 EST
Comment 6 Steve Dickson 2007-11-19 11:45:25 EST
Installing F8 on a Dell PowerEdge SC1430 I ran into this
same problem. 'edd=skipmbr' fixed the problem.
Comment 7 Christopher Brown 2008-02-07 14:07:56 EST

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.


I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Are you able to test
with either the latest release from the Fedora unity project or Fedora 9 Alpha?


If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.
Comment 8 Chuck Ebbert 2008-06-11 22:19:20 EDT
We have no reported problems with EDD any more.

Note You need to log in before you can comment on or make changes to this bug.