Bug 379471 - Revisor fails at Building media stage
Revisor fails at Building media stage
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: revisor (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Jonathan Steffan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-13 02:36 EST by redtux
Modified: 2008-01-03 11:02 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.0.5-14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-03 11:02:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description redtux 2007-11-13 02:36:42 EST
Description of problem:
After selection of ackages and dependency resolution, revisor shows a blank
screen at at building media stage. The Progress sub-windows are blank and the
following message appears in the terminal

Traceback (most recent call last):
 File "/usr/lib/python2.5/site-packages/revisor/ready_screen.py",
line 177, in button_forward_clicked
   self.gui.displayBuildMedia()
 File "/usr/lib/python2.5/site-packages/revisor/gui.py", line 277, in
displayBuildMedia
   self.BuildMedia = build_media.BuildMedia(self)
 File "/usr/lib/python2.5/site-packages/revisor/build_media.py", line
57, in __init__
   self.set_task_list()
 File "/usr/lib/python2.5/site-packages/revisor/build_media.py", line
92, in set_task_list
   if self.cfg.media_live or self.cfg.media_install:



Version-Release number of selected component (if applicable):

revisor-2.0.5-5.fc8
Comment 1 Jonathan Steffan 2007-11-13 19:11:54 EST
Please try 2.0.5-7 and see if you still have the same issue. I'm running some
tests also now. What type of media are you trying to compose?
Comment 2 Jonathan Steffan 2007-11-13 21:10:30 EST
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/revisor/ready_screen.py", line 177, in
button_forward_clicked
    self.gui.displayBuildMedia()
  File "/usr/lib/python2.5/site-packages/revisor/gui.py", line 278, in
displayBuildMedia
    self.BuildMedia.start()
  File "/usr/lib/python2.5/site-packages/revisor/build_media.py", line 65, in start
    self.base.lift_off()
  File "/usr/lib/python2.5/site-packages/revisor/base.py", line 919, in lift_off
    self.buildLiveMedia()
  File "/usr/lib/python2.5/site-packages/revisor/base.py", line 1457, in
buildLiveMedia
    liveImage.configureBootloader()
  File "/usr/lib/python2.5/site-packages/revisor/pilgrim.py", line 725, in
configureBootloader
    "%s/out/isolinux/%s" %(self.build_dir, kernel["vmlinuz"]))
  File "/usr/lib/python2.5/shutil.py", line 47, in copyfile
    fdst = open(dst, 'wb')
IOError: [Errno 13] Permission denied:
'/var/tmp/revisor-livecd/out/isolinux/vmlinuz'


This seems to have been blocked by SELinux; I'm running the same compose now
with selinux permissive.
Comment 3 Jonathan Steffan 2007-11-13 22:00:02 EST
With SELinux permissive I'm not seeing the issue in #2

Comment 4 redtux 2007-11-14 02:59:49 EST
I'm running  selinux=0 (sorry had some issues)

Revisor seems to be insisting on creating a live-cd, and if you dont select it
it fails

I'm trying to create a DVD install set
Comment 5 redtux 2007-11-15 18:17:09 EST
more frustration

I am trying to save the options as a kickstart file and I get

 revisor --kickstart-save=f8
Traceback (most recent call last):
  File "/usr/sbin/revisor", line 287, in <module>
    cfg.setup_cfg()
  File "/usr/lib/python2.5/site-packages/revisor/cfg.py", line 73, in setup_cfg
    self.options_set_from_commandline(self.cli_options)
  File "/usr/lib/python2.5/site-packages/revisor/cfg.py", line 1056, in
options_set_from_commandline
    self.kickstart_save = os.path.abspath(cli_options.kickstart_default)
  File "/usr/lib/python2.5/posixpath.py", line 402, in abspath
    if not isabs(path):
  File "/usr/lib/python2.5/posixpath.py", line 49, in isabs
    return s.startswith('/')
AttributeError: 'bool' object has no attribute 'startswith'
Comment 6 Jeroen van Meeuwen 2007-11-17 10:32:33 EST
OK this #5 issue hasn't been looked at yet, the original error for failing in
Build Media stage has been addressed in 2.0.5-9
Comment 8 redtux 2007-11-20 02:28:51 EST
With all above changes I am now getting

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/revisor/ready_screen.py", line 177, in
button_forward_clicked
    self.gui.displayBuildMedia()
  File "/usr/lib/python2.5/site-packages/revisor/gui.py", line 278, in
displayBuildMedia
    self.BuildMedia.start()
  File "/usr/lib/python2.5/site-packages/revisor/build_media.py", line 65, in start
    self.base.lift_off()
  File "/usr/lib/python2.5/site-packages/revisor/base.py", line 896, in lift_off
    self.buildInstallationMedia()
  File "/usr/lib/python2.5/site-packages/revisor/base.py", line 1051, in
buildInstallationMedia
    shutil.copy2(po.localPkg(), link_dir + "/" + os.path.basename(po.localPkg()))
  File "/usr/lib/python2.5/shutil.py", line 91, in copy2
    copyfile(src, dst)
  File "/usr/lib/python2.5/shutil.py", line 41, in copyfile
    raise Error, "`%s` and `%s` are the same file" % (src, dst)
shutil.Error: `/mnt/dvd/Fedora/kernel-xen-2.6.21-2950.fc8.i686.rpm` and
`/var/tmp/revisor-pungi/8/f8-i386/i386/os/Packages/kernel-xen-2.6.21-2950.fc8.i686.rpm`
are the same file
Comment 9 Jon Ciesla 2007-12-27 15:50:22 EST
I ran revisor on f-8, tried to create a set, and it looked like everything was
fine, but all I got in /srv/revisor/f8-i386/iso was the SHA1SUM.
Comment 10 Jeroen van Meeuwen 2008-01-03 11:02:48 EST
Jon, Seperate bug report, please

redtux, problem should have been resolved in revisor-2.0.5-14 which is in
updates now.

Note You need to log in before you can comment on or make changes to this bug.