Bug 37951 - Kickstart --ondisk option does not recognize Mylex
Summary: Kickstart --ondisk option does not recognize Mylex
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-27 00:51 UTC by Martin Lichtin
Modified: 2007-04-18 16:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-07 19:54:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ks.cfg file (1.93 KB, text/plain)
2001-04-27 17:59 UTC, Martin Lichtin
no flags Details

Description Martin Lichtin 2001-04-27 00:51:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.16-22enterprise i686)


Kickstart --ondisk option does not recognize Mylex "rd/c0d0" partition name


Reproducible: Always
Steps to Reproduce:
1. Install a Mylex RAID card, configure two logical disks.
2.  Configure partitioning in ks.cfg as
    part / --size 2048 --ondisk rd/c0/d0
3. Run "linux ks=floppy".
   anaconda will fail with the error message.
   "Autopartitioning failed."
   or similar...

Comment 1 Brent Fox 2001-04-27 15:00:54 UTC
Can you attach the kickstart file you are using?

Comment 2 Martin Lichtin 2001-04-27 17:59:06 UTC
Created attachment 16666 [details]
ks.cfg file

Comment 3 Martin Lichtin 2001-05-02 21:30:19 UTC
I tried adding --asprimary today, as there's this other bug with anaconda's
partitioning algorithm, it doesn't use all available primary partitions.

part / --size 3072 --asprimary --ondisk rd/c0d0
part swap --size 256 --ondisk rd/c0d0
part /work --size 1 --grow  --ondisk rd/c0d0
part /tmp --size 1024 --asprimary --ondisk rd/c0d0
part /var --size 1024 --asprimary --ondisk rd/c0d0

But that didn't help either, so it really looks like the --ondisk just doesn't 
like the "rd/c0do" syntax.


Comment 4 Martin Lichtin 2001-05-04 22:10:48 UTC
I finally found the problem, one has to
say --ondisk rd/c0d0p 

Thanks a lot for not helping me with this problem.
I thought we had 90 days support, but it seems you
ignore your customers.


Comment 5 Brent Fox 2001-05-07 19:54:43 UTC
I apologize for not giving this bug report more attention.  However, bugzilla is
separate from the Customer Support department.  Bugzilla is for reporting bugs
in the software and is open to anyone at any time...not just paying customers
and not just for a limited time span.  As such, I hope you can appreciate the
volume of reports that we get...it's not trivial.  I was not aware that you were
trying to access the 90 days customer support that you are entitled to.  The
website for that is www.redhat.com/support.

Comment 6 Marcel Mvckel 2002-11-15 10:21:07 UTC
I think this Problem happens not only on the Mylex Controller, its a general 
RAID Controller Problem.


Note You need to log in before you can comment on or make changes to this bug.