Bug 37992 - Kickstart install won't install Perl in some cases
Kickstart install won't install Perl in some cases
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
: 53961 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-27 00:27 EDT by Need Real Name
Modified: 2007-04-18 12:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-26 16:00:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Here is my ks.cfg file (4.66 KB, text/plain)
2001-05-09 11:55 EDT, Damon Gunther
no flags Details

  None (edit)
Description Need Real Name 2001-04-27 00:27:31 EDT
Reproduce the problem as follows:





Install Red Hat 7.1, selecting these package groups:


- networked workstation


- dialup workstation


- utilities





Complete the install, and reboot.  Confirm that Perl is present on the system.


Use mkkickstart to produce a ks.cfg. Check the newly created ks.cfg, 


and perl is listed.  Correct the partition entries in ks.cfg, delete reference to cdrom.


Re-run install over NFS using this kickstart config, and 


everything goes as planned ... except that perl doesn't get installed.





Good luck and thank you - David
Comment 1 Brent Fox 2001-04-27 15:47:18 EDT
Can you attach the kickstart file that mkkickstart made?
Comment 2 Need Real Name 2001-04-30 18:54:08 EDT
Below is a sample ks.cfg created from the install I described (except I had to go back and add mkkickstart, of course; I'd forgotten that).  From here, I correct the partition entries, delete 'cdrom' (for this example, I've also munged the encrypted root passwd), and run it.  Perl is listed here, but doesn't get installed.  

Thank you -d
--------------------------
lang en_US

network --bootproto dhcp

cdrom

device ethernet tulip

keyboard "us"

zerombr yes
clearpart --linux
part swap --size 119
install

mouse generic --device null

timezone --utc US/Central


rootpw --iscrypted &verysecret&

auth --useshadow

lilo --location mbr

%packages
glibc-common
mailcap
redhat-release
filesystem
glibc
termcap
chkconfig
db1
db3
dosfstools
eject
finger
glib
hdparm
ksymoops
losetup
mailx
mktemp
bzip2
libstdc++
MAKEDEV
mpage
info
diffutils
fileutils
findutils
gettext
ash
gzip
m4
man
ncftp
nkf
bind-utils
groff-perl
popt
procmail
psmisc
pwdb
rdate
ftp
rootfiles
rusers
sed
sendmail-cf
shadow-utils
nscd
newt
ntsysv
slocate
syslinux
tar
tcp_wrappers
telnet
mount
lilo
mouseconfig
tmpwatch
traceroute
vim-common
wget
whois
cracklib-dicts
authconfig
gpm
passwd
sh-utils
freetype
krbafs
openldap
nss_ldap
pam_krb5
SysVinit
XFree86-libs
gnupg
python
alchemist
rpm
rhn_register
util-linux
apmd
ipchains
isdn4k-utils
lokkit
openssh-clients
pidentd
nfs-utils
quota
timeconfig
anacron
chkfontpath
xtt-fonts
ghostscript
ypbind
arpwatch
dump
iproute
rsync
shapecfg
sudo
mkkickstart
ghostscript-fonts
indexhtml
redhat-logos
setup
basesystem
statserial
bdflush
cracklib
db2
dip
e2fsprogs
file
gdbm
gmp
iputils
libtermcap
lrzsz
mingetty
bash
hotplug
groff
modutils
ncurses
cpio
ed
at
gawk
grep
dhcpcd
less
make
minicom
net-tools
openssl
perl
pnm2ppa
logrotate
procps
psutils
raidtools
readline
rmt
rsh
rwho
console-tools
setserial
dev
slang
kbdconfig
setuptool
sysklogd
talk
tcl
tcsh
textutils
mkinitrd
mkbootdisk
time
crontabs
utempter
vim-minimal
which
words
pam
cyrus-sasl
kudzu
ppp
a2ps
krb5-libs
LPRng
autofs
openldap-clients
sendmail
wvdial
zlib
libpng
4Suite
python-xmlrpc
rpm-python
up2date
initscripts
devfsd
iptables
kernel
openssh
pciutils
portmap
pump
rp-pppoe
vixie-cron
XFree86-xfs
urw-fonts
VFlib2
printconf
yp-tools
bc
efax
lsof
screen
stat
stunnel

%post


Comment 3 Need Real Name 2001-05-03 08:20:58 EDT
I have the same issue. I can attach my ks.cfg file if required...
Manually installing perl in post %section gets me round the issue but it's 
irritating... 
I also loose the tcsh and nkf packages.
I found this out by doing rpm -qa and comapring the output against the package 
list in ks.cfg.
Comment 4 Damon Gunther 2001-05-09 11:53:34 EDT
I'd like to report I have the same problem. I had a hand-picked list,
but I ran into the same problem when I used mkkickstart.

perl, perl-File-MMagic, and tcsh do not make it. This is after comparing
and rpm -qa with the ks.cfg.

I see an attachment link here, I'll drop the ks.cfg file in.
Comment 5 Damon Gunther 2001-05-09 11:55:08 EDT
Created attachment 17906 [details]
Here is my ks.cfg file
Comment 6 Brent Fox 2001-06-26 16:00:21 EDT
Fixed in the latest internal build.  Thanks for your report.
Comment 7 Brent Fox 2001-09-24 12:23:35 EDT
*** Bug 53961 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.