Bug 37993 - cdrom detected by kernel but not mounted during installation
cdrom detected by kernel but not mounted during installation
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-04-27 00:40 EDT by Bill O'Kane
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-06-26 16:01:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bill O'Kane 2001-04-27 00:40:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

The kernel detects my LG CRD 8482b as a cd/dvd-rom, which it isn't,  (it 
gets the model number right) but can't find it during the installation. I 
can install 7.0 with no problem. The media is readable on other systems. 

Reproducible: Always
Steps to Reproduce:
1.Boot from floppy( won't boot from cdrom)
2.When it asks what installation media I want I select local cdrom


Actual Results:  I get an error that cdrom is not found.

The device itself is checked and working, it can boot and read other 
disks. Its a standard ATAPI/IDE 48X cdrom.
Comment 1 Brent Fox 2001-04-27 09:05:08 EDT
Try this:  make a boot floppy with the boot.img found in the /images/ directory
of the cdrom.  Boot off this floppy, and then select CDROM as the installation
type when prompted.  Does this make things work ok?
Comment 2 Bill O'Kane 2001-04-27 09:22:24 EDT
No, it will boot from the floppy but when I choose the CDROM installation type 
it gives an error "cdrom not found"
Comment 3 Edward Rudd 2001-04-29 20:17:14 EDT
I am haveing a similar problem installing RH7.1 on a system...  The CDs work in
another system. (different CD-ROM Drive) and in another system using the same
CD-ROM drive.
The kernel finds the cdrom drive, but when the installer actually tries to mount
the cd it fails and exits.    pressing alt-f3 (looking at the dmesg output)
I see that there are a series of IO read errors on the CD device..  I can read
the CD fine in RH7.0...  
What happened to the CD support in the 2.4 kernel???
Comment 4 Brent Fox 2001-05-08 11:55:58 EDT
What if you try booting with 'linux ide=nodma'.  Does that help?
Comment 5 Edward Rudd 2001-05-11 18:36:31 EDT
unfortunately no..
Comment 6 Brent Fox 2001-05-14 16:30:44 EDT
eddie, what kind of cdrom drive are you seeing the problem with?  What if you
use a different cdrom drive in the system that you were originally seeing the
problem with?
Comment 7 Brent Fox 2001-05-25 00:05:20 EDT
wrokane, I must admit that I don't know what's causing this problem.  I have not
seen this problem before.  Can you swap cdrom drives and see if that makes any
Comment 8 Bill O'Kane 2001-05-25 10:08:03 EDT
I haven't tried switching cdroms, but I have been able to install it on another 
machine with a different cdrom. I also tried remaking the iso's and attempted 
an installation on the problem machine from the hard-drive but the same sort of 
error occurs. Also tried "linux ide=nodma" and "linux hdc=ide-scsi" but neither 
works. If I get a chance this weekend I'll try a new drive in the machine.
Comment 9 Brent Fox 2001-05-31 14:05:59 EDT
Ok.  Let me know if a new drive fixes the problem.  If it does, then there could
be something wrong with the drive or with the way the kernel talks to the drive.
 Considering that the kernel does not identify the drive exactly right, that
could be the problem.  This report might need to be reassigned to the kernel.
Comment 10 Edward Rudd 2001-05-31 14:28:11 EDT
well, as this is a friends computer I can't test it very easily..
but, the nodma didn't fix it.. 
It has an AOPEN ax69pro Socket7 motherboard.and the CD is an AOPEN 40x
The CDROM drive works in an older (P133 system) fine and boots the RH7.1 CDs
so it could be the IDE controller on the motherboard.
I had copied the ISOs to his harddrive and installed 7.1 off of the Harddrive and it worked fine. and it can access the CD-ROM fine now.. 
Another system I installed RH7.1 on had a problem with the mouse.. During installation it detected and used the PS/2 mouse fine.. but after installation the system HANGS when the PS/2 mouse is accessed.. (it actually undetected the mouse and I forced it with mouseconfig)
Are the Kernels of the running system and the installation different??? that would be the only explanation for this problem..
Comment 11 Brent Fox 2001-06-04 11:38:34 EDT
Yes, the boot kernel is very stripped down compared to the normal kernel.  It
has to be smaller to fit on the boot floppy and still leave room for a few drivers.

Note You need to log in before you can comment on or make changes to this bug.