Bug 380291 - interface_info is missing after installation of policycoreutils
interface_info is missing after installation of policycoreutils
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: policycoreutils (Show other bugs)
5.1
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-13 11:08 EST by Thorsten Scherf
Modified: 2008-09-17 15:28 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-17 15:27:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thorsten Scherf 2007-11-13 11:08:25 EST
Description of problem:
when I run audit2allow -R the mention file is required in order use interfaces.
the file is missing on a test machine where I manually installed the selinux
packages. Looks like this line is responsible for this:

--scripts:
[ -f /usr/share/selinux/devel/include/build.conf ] && /usr/bin/sepolgen-ifgen  >
/dev/null

this means selinux-policy-devel is required for policycoreutils to get the file
installed?!


Version-Release number of selected component (if applicable):
policycoreutils-2.0.31-7.fc8

How reproducible:
install policy-policy-devel after policycoreutils 

Steps to Reproduce:
1.see above
2.
3.
  
Actual results:
interface_info is missing

Expected results:
interface_info file is available

Additional info:
Comment 1 Daniel Walsh 2008-09-17 15:27:14 EDT
I previous bugzilla asked me to remove this requires to help slim packageing.
Comment 2 Daniel Walsh 2008-09-17 15:28:26 EDT
Actually I will add it to policycoreutils-gui, which seems like a decent compromize.

Note You need to log in before you can comment on or make changes to this bug.