Bug 380321 - snmpd proc statement reports 0 processes running for all procs
snmpd proc statement reports 0 processes running for all procs
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: net-snmp (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Jan Safranek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-13 11:23 EST by Aran Cox
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 5.4.1-5.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-26 13:54:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aran Cox 2007-11-13 11:23:33 EST
Description of problem:
The prTable reports all processes monitored with "proc" statement as have 0
processes running.

Version-Release number of selected component (if applicable):
net-snmp-5.4.1-4.fc8

How reproducible:
Trivially, just add a proc statement and walk the prTable.

Steps to Reproduce:
1. add something like: proc sshd to snmpd.conf
2. restart snmpd
3. walk prTable (snmpwalk -v 2c -c public localhost prTable)


Actual results:
Shows 0 processes, even when there are processes running.

Expected results:
should show number of sshd processes running.  Note, sshd is just an example,
it's true of all processes I tested.

Additional info:
The issue is that snmpd doesn't invoke ps... it's supposed to us ps acx, but if
you strace the snmpd process it shows this:

17546 execve("", ["", "-acx"], [/* 21 vars */]) = -1 ENOENT (No such file or
directory)

It's like the ps program wasn't found, or the path to it wasn't compiled in
properly.
Comment 1 Jan Safranek 2007-11-15 04:35:42 EST
Thanks for the report, I am able to reproduce it and I'll look what is wrong.
Comment 2 Jan Safranek 2007-11-15 05:47:29 EST
Oh, from some reason 'ps' is not in the default buildroot anymore -> ./configure
script cannot find it -> prTable does not work.

I added appropriate build-dependency and net-snmp should be fine in next release
(I will not release update just because of this bug).
Comment 3 Fedora Update System 2007-11-20 12:49:45 EST
net-snmp-5.4.1-5.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update net-snmp'
Comment 4 Fedora Update System 2007-11-26 13:54:31 EST
net-snmp-5.4.1-5.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.