Bug 380451 - yum/rpm hangs on searching & parsing
yum/rpm hangs on searching & parsing
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-13 12:12 EST by Sai Kiran Kanuri
Modified: 2014-01-21 18:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-06 23:08:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sai Kiran Kanuri 2007-11-13 12:12:55 EST
Description of problem:
cron.daily rpm task, rpm -qa "package", yum search package, yum install
something, all these commands hang. No error messages. they just get stuck
there. Control-C also doesn't work.

We need to o a kill -9 to get rid of the process

Version-Release number of selected component (if applicable):
I just checked it on my PC. newly installed with additional repos enabled. I
have also installed livna release rpm. No updates done after that.

How reproducible:



Steps to Reproduce:
1.
2.
3.
  
Actual results:
no output appears

Expected results:
queries should work

Additional info:
Comment 1 Panu Matilainen 2007-11-13 13:40:49 EST
Once you kill any rpm-related process with kill -9, you'll need to clean up
rpmdb locks manually to resume normal functionality: rm -f /var/lib/rpm/__*
Comment 2 Seth Vidal 2007-12-06 23:08:46 EST
closing as this seems to be a workaround.

Note You need to log in before you can comment on or make changes to this bug.