Bug 380471 - Amarok, taglib problems with WMA files
Amarok, taglib problems with WMA files
Status: CLOSED DUPLICATE of bug 346011
Product: Fedora
Classification: Fedora
Component: amarok (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-13 12:13 EST by Steven Stern
Modified: 2007-11-30 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-29 19:44:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The Crash Report Done by Amarok (2.64 KB, application/octet-stream)
2007-11-16 09:38 EST, Clifton
no flags Details

  None (edit)
Description Steven Stern 2007-11-13 12:13:55 EST
Description of problem:
Amarok fails on a clean install of F8 when attempting to build its collection
when parsing WMA files

Version-Release number of selected component (if applicable):
amarok 1.4.7-7

How reproducible:
Start amarok and let it build the collection.


Result:
Amarok fails with "errors in taglib".


Additional info:


amarok-extras-nonfree-1.4.4-1.lvn7
amarok-1.4.7-7.fc8
libmad-0.15.1b-5.lvn8
ffmpeg-libs-0.4.9-0.41.20071011.lvn8
amarok-extras-nonfree-1.4.4-1.lvn7
xvidcore-1.1.3-1.lvn8
faac-1.25-4.lvn8
vcdimager-0.7.23-3.lvn6
mplayer-1.0-0.88.rc2.lvn8
lame-libs-3.97-6.lvn8
x264-0-0.10.20070819.lvn8
mplayerplug-in-3.45-2.lvn8
xine-lib-extras-nonfree-1.1.8-4.lvn8
totem-xine-2.20.1-1.lvn8
libdvdnav-0.1.10-4.20070503.lvn8
libdca-0.0.5-2.lvn8
a52dec-0.7.4-11.lvn8
faad2-2.0-21.20050131.lvn8
taglib-1.5-0.6.20071111svn.fc8
Comment 1 jason222 2007-11-15 11:31:06 EST
I get the same thing happening to me as well.

Additionally it will not add WMA files to the playlist manually either, crashing
or freezing when they are added.

How to reproduce: Try to add any WMA file to the playlist

Result: Program generally crashes (or freezes. It has not worked at all for me).
Comment 2 Dean Mander 2007-11-15 15:04:53 EST
I confirm same bug on x86_64.

For me it's even worse: I can't use amarok anymore, it always got stuck on
loading his "collection" (which contains several wma files).

When I try to drag&drop files from konqueror fileview, it crashes most of the time.

I've tested with taglib
1.5-0.5.20070924svn.fc8.x86_64
1.5-0.6.20071111svn.fc9.x86_64
1.4-5.fc7.x86_64

and amarok
1.4.7-7.fc8.x86_64
1.4.7-8.fc9.x86_64

Comment 3 Rex Dieter 2007-11-15 15:16:07 EST
We know, and are working on it.  For now, the best suggestion is to not use wma
files (in f8), omit them from your amarok music collection.
Comment 4 Aniket 2007-11-15 15:59:16 EST
I was also able to reproduce the bug. 
amarok-1.4.7-7.fc8
taglib-1.5-0.6.20071111svn.fc8

latest taglib build from koji. 
I also saw amarokcollection segfault messages in syslog
Comment 5 Rex Dieter 2007-11-15 16:11:25 EST
No more "me toos" please.  Don't make me go postal!
Constructive additions (like patches or additional debugging hints) are
certainly welcome. :)
Comment 6 Clifton 2007-11-16 09:38:58 EST
Created attachment 261271 [details]
The Crash Report Done by Amarok
Comment 7 zeppelinpub 2007-11-19 13:05:28 EST
Im having the same problem
Comment 8 Kyle Pablo 2007-11-29 19:36:58 EST
Same issue on x86_64
Comment 9 Rex Dieter 2007-11-29 19:44:38 EST

*** This bug has been marked as a duplicate of 346011 ***
Comment 10 Rex Dieter 2007-11-29 19:45:54 EST
postal!  just kidding. :)

Note You need to log in before you can comment on or make changes to this bug.