Bug 380651 - pungi incorrectly includes .i386 dependencies for .x86_64 rpms
pungi incorrectly includes .i386 dependencies for .x86_64 rpms
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pungi (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-13 13:35 EST by Josh Cogliati
Modified: 2013-01-09 20:43 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 14:59:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Cogliati 2007-11-13 13:35:14 EST
Description of problem:
In the package section of the kickstart file, I have the following package:
R-devel.x86_64
Because of this, pungi includes the following files:
R-2.6.0-3.fc8.1.i386.rpm          
R-devel-2.6.0-3.fc8.1.x86_64.rpm
R-2.6.0-3.fc8.1.x86_64.rpm  
This adds extra space to the resulting distribution because pungi adds the i386
dependency when it should not.  

I also tried adding
-*.i386
-*.i586
-*.i686 
to the package section to see if that would get rid of them.  It did not.



Version-Release number of selected component (if applicable):
pungi-1.1.9-1.fc8

How reproducible:
Put in either R-devel.x86_64 or R-devel and see the i386 version of R added.

Steps to Reproduce:
1. Create kickstarte file for Fedora 8 x86_64 version
2. Include R-devel.x86_64 as package (or other packages with i386 versions included)
3. Watch the non-dependency R.i386 appear in when gathering is done.
  
Actual results:
Gathered packages:
R-2.6.0-3.fc8.1.i386.rpm          
R-devel-2.6.0-3.fc8.1.x86_64.rpm
R-2.6.0-3.fc8.1.x86_64.rpm 

Expected results:
Gathered packages:
R-devel-2.6.0-3.fc8.1.x86_64.rpm
R-2.6.0-3.fc8.1.x86_64.rpm
Comment 1 Jesse Keating 2007-11-15 14:59:33 EST
You would have to add an exclude line at the repo declaration to exclude the
secondary arch.  In order to make sure we can satisfy any secondary arch needs
at install time, we have to be overly sure we have all possible secondary arch
needs at compose time.

Note You need to log in before you can comment on or make changes to this bug.