Bug 380881 - Leftover .orig file patched by a .src.rpm .patch file
Leftover .orig file patched by a .src.rpm .patch file
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gdb (Show other bugs)
4.6
All Linux
low Severity low
: ---
: ---
Assigned To: Jan Kratochvil
: EasyFix
Depends On: 380851
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-13 15:13 EST by Jan Kratochvil
Modified: 2008-07-24 15:56 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2008-0717
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 15:56:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan Kratochvil 2007-11-13 15:13:08 EST
Description of problem:
`gdb/linux-nat.c.orig' file is accidentally being patched.
While the package passed Brew/Rpmdiff/RHEL-4 builds in some system
configurations (env $SIMPLE_BACKUP_SUFFIX) and/or on non-RHEL-4 systems the
--rebuild of the package may fail due to the missing .orig file there.

Version-Release number of selected component (if applicable):
gdb-6.3.0.0-1.153.el4

How reproducible:
Always.

Steps to Reproduce:
1. SIMPLE_BACKUP_SUFFIX=foo rpmbuild --rebuild gdb-6.3.0.0-1.153.el4.src.rpm

Actual results:
+ echo 'Patch #112 (gdb-6.3-scheduler_locking-step-sw-watchpoints2.patch):'
Patch #112 (gdb-6.3-scheduler_locking-step-sw-watchpoints2.patch):
+ patch -p1 -s
The text leading up to this was:
--------------------------
|diff -u -rup gdb-6.3-orig/gdb/linux-nat.c.orig gdb-6.3/gdb/linux-nat.c.orig
|--- gdb-6.3-orig/gdb/linux-nat.c.orig  2004-10-08 22:29:47.000000000 +0200
|+++ gdb-6.3/gdb/linux-nat.c.orig       2007-07-27 15:59:39.000000000 +0200
--------------------------
File to patch: 

Expected results:
Successfully rebuilt package.

Additional info:
Sure just the .orig part of the patch should be removed.
Submitted a Rpmdiff Bug 380851 that this problem could be checked automatically.
Comment 1 RHEL Product and Program Management 2007-11-28 22:55:21 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 errata-xmlrpc 2008-07-24 15:56:44 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0717.html

Note You need to log in before you can comment on or make changes to this bug.