Bug 38094 - Kernel 2.2.19-7.0.1 reports 0 shared memory usage
Summary: Kernel 2.2.19-7.0.1 reports 0 shared memory usage
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 39545 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-27 14:47 UTC by Juan Jose Comellas
Modified: 2007-04-18 16:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-27 14:47:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Juan Jose Comellas 2001-04-27 14:47:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.19 i686)


After upgrading my Red Hat 7.0 machines with kernel-2.2.19-7.0.1 the kernel
always reports 0 shared memory and 0 swap usage. I suspect this is not true
because my machines are working correctly. Here is the output of the memory
status reported by the kernel:

$ cat /proc/meminfo
        total:    used:    free:  shared: buffers:  cached:
Mem:  535310336 532930560  2379776        0 269357056 163246080
Swap: 1077501952        0 1077501952
MemTotal:    522764 kB
MemFree:       2324 kB
MemShared:        0 kB
Buffers:     263044 kB
Cached:      159420 kB
BigTotal:         0 kB
BigFree:          0 kB
SwapTotal:  1052248 kB
SwapFree:   1052248 kB

Reproducible: Always
Steps to Reproduce:
1. cat /proc/meminfo


Actual Results:  The kernel reports 0 shared memory and swap usage:

        total:    used:    free:  shared: buffers:  cached:
Mem:  535310336 532930560  2379776        0 269357056 163246080
Swap: 1077501952        0 1077501952
MemTotal:    522764 kB
MemFree:       2324 kB
MemShared:        0 kB
Buffers:     263044 kB
Cached:      159420 kB
BigTotal:         0 kB
BigFree:          0 kB
SwapTotal:  1052248 kB
SwapFree:   1052248 kB


Expected Results:  The kernel should have reported at least 200 MB shared
memory usage.

This doesn't happen if I use the standard 2.2.19 kernel or the 2.2.16-22
and 2.2.17-14 Red Hat kernel versions.

Comment 1 Arjan van de Ven 2001-04-27 14:50:40 UTC
Newer kernels (2.2.19 and 2.4) no longer report shared memory as the accounting
for that was a significant performance impact.

Comment 2 Daniel Roesen 2001-04-27 17:14:38 UTC
2.2.19 does:

$ cat /proc/meminfo 
        total:    used:    free:  shared: buffers:  cached:
Mem:  131125248 58826752 72298496 35450880 25706496  7979008
Swap: 135241728        0 135241728
MemTotal:    128052 kB
MemFree:      70604 kB
MemShared:    34620 kB
Buffers:      25104 kB
Cached:        7792 kB
SwapTotal:   132072 kB
SwapFree:    132072 kB
$ uname -r
2.2.19


Comment 3 giulioo 2001-05-08 21:36:18 UTC
*** Bug 39545 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.