Bug 38098 - installer crashes on testing video Cirrus Logic GD544x
installer crashes on testing video Cirrus Logic GD544x
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-27 11:57 EDT by ashworth
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-17 16:43:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
crash file from anaconda (10.08 KB, text/plain)
2001-04-27 11:59 EDT, ashworth
no flags Details

  None (edit)
Description ashworth 2001-04-27 11:57:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [en] (Win98; I)


Compaq Proliant 1600. Cirrus Logic GD544x, IBM monitor.  Installed 7.1, clean, upon reboot, it's not able to go into video mode, can't see the 
login screen, it's black.  Have tried to re-install several times, last two times the installer crashed when I hit the test video button.  V7.0 worked 
fine with this same hardware config.

Reproducible: Always
Steps to Reproduce:
1. Install 7.1
2.reboot
3.no video image
	

Actual Results:  don't get a video image. appears the system is up, I can type "blind" and it appears the system is logging in, just no video 
image (it blinks a little, but that's it)

Expected Results:  Got a video image.

Noticed other bug reports.  Appears that the installer isn't setting up the X stuff correctly??
Comment 1 ashworth 2001-04-27 11:59:12 EDT
Created attachment 16665 [details]
crash file from anaconda
Comment 2 Mike A. Harris 2001-05-18 00:32:35 EDT
This is a bug XFree86 mainly.  Acceleration is broken in the Cirrus
Logic driver.  We didn't know this in advance unfortunately.  The workaround
is to manually configure XFree86 after installation instead with:

Xconfigurator --preferxf4 --nodri

Then edit the config file /etc/X11/XF86Config-4 and add a new option:

Option
"noaccel"

This should get you up and running.  The installer is fixed in rawhide to
default this driver to noaccel in the future, and there is another bug
open for this against XFree86 already.  The above workaround should work
for you.

Note You need to log in before you can comment on or make changes to this bug.