Bug 38132 - initscripts dont always redial on hangup
initscripts dont always redial on hangup
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-27 18:09 EDT by Henri Schlereth
Modified: 2014-03-16 22:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-11 00:17:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henri Schlereth 2001-04-27 18:09:27 EDT
In all previous versions up to 7.0 the modem hangup would generate a redial
within
2 minutes. Three times so far the new scripts have hungup and not redialed.
This is possibly an issue with ppp but I thought I would file it first
under initscripts.
This is a firewall/ppp server upgraded from 7.0

I have never put any of the Rawhide releases on here.
Comment 1 Colin Manning 2001-05-04 03:44:35 EDT
I have a 7.1 virgin install that was doing the same thing.
The problem was that the persist option was not being passed to the pppd 
command line. I modified the PPPOPTIONS entry and added the persist to this to 
make it work - not the right way, but I will look into that later tonight.
Comment 2 Colin Manning 2001-05-04 20:22:49 EDT
Hmmm.... So if I use ppp-watch I shouldn't need the persist option for pppd. -
Anyway my previous solution still works.

On my 7.1 install:
ps axww | grep ppp-watch returns a COMMAND of 
/sbin/ppp-watch ppp0 iffcg-ppp0 boot

ps axww | grep ppp-watch returns a COMMAND of 
/usr/sbin/pppd -detach lock modem crtscts asyncmap 00000000 defaultroute
usepeerdns user ____ remotename ppp0 /dev/ttyS0 115200 ipparam ppp0 linkname
ppp0 call ppp0 noauth passive persist

I have added passive and persist using the PPPOPTIONS variable.

On my 7.0 install:
ps axww | grep ppp-watch returns a COMMAND of 
/sbin/ppp-watch ppp0 boot
ps axww | grep ppp-watch returns a COMMAND of 
/usr/sbin/pppd lock modem crtscts asyncmap 00000000 defaultroute usepeerdns user
____ remotename ppp0 debug nodetach /dev/ttyS0 115200 ipparam ppp0 linkname ppp0
noauth passive connect /usr/sbin/chat -v -f
/etc/sysconfig/network-scripts/chat-ppp0                                                                               

This install still has debug turned on, and passive was added using the
PPPOPTIONS var again.

Hope this helps someone figure it out. I'll keep you posted on what I find.
Comment 3 Alex Kanavin 2001-05-14 14:30:25 EDT
This problem might be a duplicate of ppp-watch bug #39231, please check the fix
provided there and tell if anything changes or not.
Comment 4 Henri Schlereth 2001-06-11 00:17:37 EDT
Added persist in PPPOPTIONS in ifcfg-ppp0 and it now redials after
disconnect/hangup.
Thanks to ak on this. initscripts*88 isnt out yet in rawhide but .86 didnt fix
this problem.
Comment 5 Bill Nottingham 2001-08-09 01:21:01 EDT
.88 should fix this, afaik.

Note You need to log in before you can comment on or make changes to this bug.