Bug 38152 - (SiS 620)No screen refresh drag and drop on the desktop (black screen)
Summary: (SiS 620)No screen refresh drag and drop on the desktop (black screen)
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
: 53995 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-28 03:17 UTC by Need Real Name
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-09 11:19:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XF86 Config file (15.15 KB, text/plain)
2001-05-16 02:34 UTC, Need Real Name
no flags Details
XF86 Config-4 file (5.50 KB, text/plain)
2001-05-16 02:36 UTC, Need Real Name
no flags Details
XF log file , wish best of luck to finf problem: Thanks (13.33 KB, text/plain)
2001-05-16 02:38 UTC, Need Real Name
no flags Details

Description Need Real Name 2001-04-28 03:17:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [fr] (X11; U; Linux 2.4.2-2 i686)


When using grag/drop feature on the desktop, ther is no refresh of the
screen. Need tominimize and maximise menu to refresh screen

Reproducible: Always
Steps to Reproduce:
1.Select (left mouse click) an icon
2.Drag on desktop
3.
	

Actual Results:  Part of screen where mouse traveled goes black

Expected Results:  Background to be untouched (refreshed)

First report, I hope it is helpfull

Comment 1 Need Real Name 2001-04-29 02:03:56 UTC
On SIS 630 video card

Comment 2 Need Real Name 2001-04-29 02:04:40 UTC
On SIS 620 video card

Comment 3 Bernhard Rosenkraenzer 2001-04-30 17:26:17 UTC
Works for me (ATI M4 and Matrox G200); unless it's a local problem, it's a bug 
in the X driver for your graphics card. Reassigning.


Comment 4 Need Real Name 2001-05-01 01:12:27 UTC
If this helps, here is the hardware:

Motherboard:   SystemBoard M748LMRT ,
Video:             included in motherboard, SYS 620 which uses 8Mb of RAM
256 Mb of RAM
P II 400 MHz CPU

Comment 5 Mike A. Harris 2001-05-15 09:01:09 UTC
I have an idea what the problem might be, but I don't have the hardware
to test with.  I will need a copy of your /etc/X11/XF86Config, your
/etc/X11/XF86Config-4, and your /var/log/XFree86.0.log to investigate the
issue deeper.  Please attach those files via our file attachment link below.


Comment 6 Need Real Name 2001-05-16 02:34:14 UTC
Created attachment 18551 [details]
XF86 Config file

Comment 7 Need Real Name 2001-05-16 02:36:47 UTC
Created attachment 18552 [details]
XF86 Config-4 file

Comment 8 Need Real Name 2001-05-16 02:38:33 UTC
Created attachment 18553 [details]
XF log file , wish best of luck to finf problem: Thanks

Comment 9 Need Real Name 2001-05-16 02:46:16 UTC
Attached the 3 files. I have tried the Mandrake version (sorry) but gave the 
same behaviour. Will revert to Red Hat.

Comment 10 Need Real Name 2001-05-26 00:24:57 UTC
Hi M. Harris,

Any news about what is wrong with the setup,

Thanks,
Yves.

Comment 11 Need Real Name 2001-07-03 00:52:36 UTC
I wonder if this is related to bug 46805?

Comment 12 Alexei Podtelezhnikov 2001-07-03 05:27:10 UTC
The provided config files are not not from Xconfigurator or anaconda. May I 
suggest that you back up your configuration and try Xconfigurator (from updates 
or rawhide at ftp.redhat.com) instead? I would also use just 1024x768x16bpp 
(nothing else, as a test).

Comment 13 Need Real Name 2001-07-04 00:18:47 UTC
Hi,
Thanks for looking into this. The problem might be related to bug 46805.
I have tried the suggestion,1024x768x16bpp with XConfigurator and restarted the 
XWindow server. Still the same result.
I  want to add that starting the Xconfig in a XTerm, I got a warning:
 Xlib:  extension "RENDER" missing on display ":0.0".  
It seams that all other apps show this warning in the Xterm (I did not use command 
line to start apps before). I do not know what the system is expecting.
Thanks,Yves.

Comment 14 Mike A. Harris 2001-10-22 05:45:59 UTC
It is not a warning.  RENDER extension missing is just information.
Harmless information, ignore it.

Comment 15 Mike A. Harris 2001-10-22 05:48:36 UTC
*** Bug 53995 has been marked as a duplicate of this bug. ***

Comment 16 Mike A. Harris 2002-03-09 11:19:35 UTC
Steps to fix:

1) Run "Xconfigurator  --preferxf4"
2) After that, edit /etc/X11/XF86Config-4
3) In the device section add the following 2 lines

Option  "swcursor"
Option  "noaccel"

If the problem goes away, which I believe it will, let me know and we
can fine tune the troubleshooting.  If the problem is gone in a newer version,
also please let me know as I do not have this hardware.

Thanks.

Comment 17 Mike A. Harris 2002-03-11 03:03:53 UTC
The above suggested settings have been made the default in rawhide.


Comment 18 Need Real Name 2002-03-12 00:24:44 UTC
This problem goes away for me with XFree 4.1,
either OpenLinux 3.1.1 or RedHat 7.2


Note You need to log in before you can comment on or make changes to this bug.