Bug 381521 - Transifex lack of a generic interface to download .po files
Transifex lack of a generic interface to download .po files
Status: CLOSED WONTFIX
Product: Fedora Localization
Classification: Fedora
Component: Website (Show other bugs)
unspecified
All Linux
high Severity high
: ---
: ---
Assigned To: Dimitris Glezos
Diego Búrigo Zacarão
:
: 396321 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-13 23:22 EST by Chester Cheng
Modified: 2016-06-23 00:45 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-21 13:57:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chester Cheng 2007-11-13 23:22:55 EST
Description of problem:
Difficult to get a .po file from transifex because of its lacking of generic
interface

Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1. Connect to transifex
2. Get .po files from different kinds of repos, such as git, hg, etc.
3.
  
Actual results:
transifex redirects users to the web interfaces of different repos.

Expected results:
A generic web interface so users don't need to care about what repo they connect to.

Additional info:
Comment 1 Dimitris Glezos 2007-11-16 02:29:46 EST
Transifex currently is focused on the "push" part of the workflow, since "pull"
is handled pretty well by Damned Lies, even with POT-merged files. Coding
fetching in Transifex (as well) wouldn't be hard (POT merging needs work, and
maybe other checks I am overlooking).

We could link to the stats page from the transifex module pages very quickly, so
that translators can see all the info they need from there and fetch the PO
files. Is this solution something that could cover our needs?
Comment 2 Chester Cheng 2007-11-18 19:18:28 EST
The goal here is to offer simple, generic interface for translators who work
only on their .po files.  I don't see any problem if the stats page you mention
here is in the same look.

Cheers,
Chester
Comment 3 Dimitris Glezos 2007-11-23 03:02:57 EST
*** Bug 396321 has been marked as a duplicate of this bug. ***
Comment 4 Dimitris Glezos 2008-01-31 20:01:04 EST
I just committed an update that adds a graphical link on Tx's module page which
links to the statistics page:

  http://glezos.fedorapeople.org/transifex/link-to-stats.png

Should be live with our next package update on the app servers.

The way we designed it, both websites use the same URL structure, menus,
look-and-feel and content, and avoid mentioning each other, so they feel more or
less as a single one. Adding more links between them enhances this feeling and
saves users time. This fix will definitely help people get their files easier
from inside Tx.

Keeping the report open to remind us to continue working in integrating the
tools better.
Comment 5 Chester Cheng 2008-02-01 01:13:41 EST
Sorry to be picky here.  Just wondering if the process can be much simpler for
computer dummies like me?

All I need is a page where I can download all the .po file of my language, and a
page where I can upload the file I translated without worrying about the
filename on the server.

BTW, this could be an error:  From the web page
https://translate.fedoraproject.org/submit/ it takes me 5 clicks (too many
clicks) to get an anaconda file and the actual result is a 404 error.

==========
Not Found

The requested URL
/translation/POT/anaconda.rhel5-branch/anaconda.rhel5-branch.zh_TW.po was not
found on this server.
==========
Comment 6 Asgeir Frimannsson 2008-02-01 02:00:36 EST
(In reply to comment #5)
> Sorry to be picky here.  Just wondering if the process can be much simpler for
> computer dummies like me?
> 
> All I need is a page where I can download all the .po file of my language, and a
> page where I can upload the file I translated without worrying about the
> filename on the server.

No reason to apologize, thank you for bringing up the usability issues. We are
looking into how we can make the link from the statistics page (for downloading
PO and POTs) to the submit page.

Perhaps the submit page could be made more language dependent. Eg. when a
translator is on the statistics page, he clicks the submit button for a module
in the list, and that will take him to the submit page for that specific file
without having to specify a file name or such. He uploads the file, verifies the
diff and optionally ads a specific commit message (a default commit message
should be created like 'updating Norwegian nb translation'). After submission
the translator can click a link to return to the statistics page.

One issue here is that the statistics page won't be updated straight away. Hm..
perhaps we could implement a ping-back system so that we can visually see which
modules are not yet updated..

Comment 7 Asgeir Frimannsson 2008-02-01 02:13:54 EST
(In reply to comment #5)
> BTW, this could be an error:  From the web page
> https://translate.fedoraproject.org/submit/ it takes me 5 clicks (too many
> clicks) to get an anaconda file and the actual result is a 404 error.
> 
> ==========
> Not Found
> 
> The requested URL
> /translation/POT/anaconda.rhel5-branch/anaconda.rhel5-branch.zh_TW.po was not
> found on this server.
> ==========

Yes, this seems to be a bug with the handling of git repositories in Damned
Lies. Bug #431173 registered.

https://bugzilla.redhat.com/show_bug.cgi?id=431173
Comment 8 Dimitris Glezos 2008-02-14 09:17:53 EST
Confirming that the link from "Submit" to "Stats" has gone live (small pie chart
icon). Now going from the Transifex module page to the downloadable PO files is
2 clicks away.

I added to my TODO a feature to allow form pre-filling from variables in the URL
(and even form submitting), so that we can go from Stats to Upload in 2 clicks
or so.
Comment 9 Tony Fu 2008-09-09 23:18:58 EDT
requested by Jens Petersen (#27995)
Comment 10 Piotr Drąg 2009-03-21 13:57:31 EDT
Closing bugs related to deprecated DL/Tx 0.3 combo.

Note You need to log in before you can comment on or make changes to this bug.