Bug 38155 - keyboard and mouse stopped working and won't start after reboot
keyboard and mouse stopped working and won't start after reboot
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-27 23:41 EDT by Kervin Pierre
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-15 15:02:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/message and XFree logs tarred and gziped (26.67 KB, application/octet-stream)
2001-05-15 11:08 EDT, Kervin Pierre
no flags Details

  None (edit)
Description Kervin Pierre 2001-04-27 23:41:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)


I don't know what went wrong, I was just minding my business surfing with
netscape 4.76 when my mouse and keyboard stoped working.  I logged in via
ssh and restarted.  I have not been able to use by keyboard and mouse
since.  There was no one else on the computer at the time and I was in X
running a few xterms, xmms, and netscape.  I've shutdown all servers except
portmap and sshd prior to this so I don't it's some over applications
fault.

Note this may have nothing to do with console tools, but bugzilla insist
that I fill in a component and there isn't a 'unknown' component.  I think
a 'unknown' component should be added.

Any help on this would be appreciatted

Reproducible: Didn't try
Steps to Reproduce:
1.?
2.
3.
	

Actual Results:  I don't know how to reproduce it.  The keyboard and mouse
stopped working whiles I was surfing and won't work even after reboot.

Expected Results:  the keyboard and mouse should work

7.1 fresh install on 450PII 128MEGS
Comment 1 Bernhard Rosenkraenzer 2001-05-01 17:22:36 EDT
This is probably an XFree86 driver problem (which graphics card are you 
using?) and almost certainly not reproducable.
Comment 2 Kervin Pierre 2001-05-02 18:44:30 EDT
Thanks for replying.

I have a ATI rage 128.

I boot into run level 3, but I still don't have keyboard/mouse.  And what reply
puzzles me is that this problem survives a reboot, even if I've made no config
changes.

Are there any trouble shooting steps you can recommend.  As of today I still
can't use my workstation (I have to log in using ssh and exceed).
Comment 3 Rob Vandelay 2001-05-04 16:59:27 EDT
I experienced exactly the same thing with my Red Hat 7.1 install. It had been 
working perfectly for the last two weeks. One day I shut the machine down, the 
correct way so all the procs got the TERM SIG and all the services shutdown. 
Then the next day when I turned it on the keyboard and mouse didn't work. This 
is before X Windows even starts. Durring boot up I can hit Caps Lock on the 
keyboard and the light will go on and off reflecting the changes but as soon as 
the boot up finishes and the logon prompt appears I can no longer hit caps and 
have the light go on and off. The strange thing is that I completly reinstalled 
RH linux on the machine and the same thing occurs. No keyboard or mouse. There 
is no SSH daemon running (nor telnet) so I can not get to the machine at all.


Machine specs:
Processor: Intel Celeron/533
Grpahics: Intel i810 onboard AGP
RAM: 64 MB
NIC: 3Com 905B
HD: 15 GB Maxtor
Keybord: Tried standard HP keyboard and Dell keyboard from other machine.
Mouse: Tried HP's original mouse and a Microsoft Intellimouse both PS/2.
Software: All software is from the original install of Red Hat Linux 7.2.
Comment 4 Mike A. Harris 2001-05-15 06:53:01 EDT
This problem sounds very strange to me.  I would guess hardware failure,
however I don't want to jump the gun.  Aside from hardware failure, the
only thing that makes any sense is that your configuration has changed
somehow to something incompatible.  I recommend rerunning Xconfigurator
and trying again.  Are you using USB keyboard or mouse?  Please provide
accurate hardware details, copies of XFree86 logs, XFree86 config files,
and your /var/log/messages file.  Attach them all as plain text files
using the hyperlink below.
Comment 5 Kervin Pierre 2001-05-15 10:56:02 EDT
mharris,

I think is the kernel.  I've been following the kernel mailing list, and Alan
reported that there have been quite a few "keyboard lockup" and "keyboard stop
responding" problems with the 2.4.2 kernel.  I'm not sure yet, later today I'll
recompile the kernel and see if that fixes things.

I have a microsoft PS2 wheelmouse and a PS2 keyboard.  I think someone on the
kernel list mentioned some of the lockup problems are related PS2.

Can it still be X even if my keyboard does not work in runlevel 3?  I'm booting
into runlevel 3.  If you still think it might be X I'll send you my X
configuration.
Comment 6 Kervin Pierre 2001-05-15 11:08:58 EDT
Created attachment 18451 [details]
/var/log/message and XFree logs tarred and gziped
Comment 7 Kervin Pierre 2001-05-15 13:43:06 EDT
upgrading the kernel to 2.4.4 fixed the problem.
Comment 8 Arjan van de Ven 2001-05-15 13:45:17 EDT
Thanks for testing that. The interesting question (for me) is if our current
kernel in rawhide (2.4.3-2.14.X) is also fixed. It's very close to a 2.4.4
kernel codewise, so I'd assume so, but assuming != knowing for sure.
Comment 9 Rob Vandelay 2001-05-15 15:02:44 EDT
After upgrading to mouseconfig-4.22-1 the mouse and keyboard still did not work 
after rebooting. Later I SSH'ed in from another machine and changed 
the /etc/sysconfig/mouse file. Originaly it said DEVICE="/dev/mouse" I changed 
it to DEVICE="/dev/psaux" and now everyting works fine. The keboard and the 
mouse do not lockup anymore.
Comment 10 Mike A. Harris 2001-06-12 03:01:26 EDT
Ok, great.  Thanks for testing out the new packages.  Glad they're working
for you.

Note You need to log in before you can comment on or make changes to this bug.