Bug 381571 - NetworkManager starts bind needlessly
NetworkManager starts bind needlessly
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
: 390191 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-14 00:24 EST by Philippe Troin
Modified: 2008-01-06 20:18 EST (History)
3 users (show)

See Also:
Fixed In Version: 0.7.0-0.6.6.svn3138.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-06 20:18:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philippe Troin 2007-11-14 00:24:12 EST
/etc/init.d/NetworkManager starts the "bind" service.

When NetworkManager was using dhcdbd (pre-F8), it made sense to have named
started as resolv.conf was always pointing to the localhost named instance.
Now that dhcdbd is gone, NetworkManager should not need named.

BTW, I think that dhcdbd was a better approach, as the local named instance
would try to query the DHCP-provided DNS server and was falling back to
resolving from the root servers if the (DHCP-provided) forwarders were not
responsive.
Any chance to have dhcdbd back?

Phil.
Comment 1 Dan Williams 2007-11-26 11:18:39 EST
*** Bug 390191 has been marked as a duplicate of this bug. ***
Comment 2 Fedora Update System 2007-12-07 16:34:26 EST
NetworkManager-0.7.0-0.6.6.svn3138.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'
Comment 3 Fedora Update System 2008-01-06 20:18:34 EST
NetworkManager-0.7.0-0.6.6.svn3138.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.