Bug 381631 - No more color ls output by default
No more color ls output by default
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: setup (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Phil Knirsch
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-14 00:44 EST by Tomasz Kepczynski
Modified: 2015-03-04 20:19 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-22 11:02:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tomasz Kepczynski 2007-11-14 00:44:30 EST
Description of problem:
Terminal sessions in KDE (in konsole) lack color ls by default
which used to work in FC6.
VT console is OK.

Version-Release number of selected component (if applicable):
setup-2.5.58-1.el5.noarch

How reproducible:
Always

Steps to Reproduce:
Just try plain "ls" on vt and in konsole and see the
difference.
  
Actual results:
Plain ls output.

Expected results:
Color ls output.

Additional info:
This is due to this change:
https://bugzilla.redhat.com/show_bug.cgi?id=199817#c5
Shell loaded by konsole is not a login shell and therefore
/etc/profile.d/colorls.csh will not be sourced due to that
change.
Either revert the change, change konsole configuration
to load login shell or rethink where coreutils should
put contents of /etc/profile.d/colorls.csh.
Comment 1 Phil Knirsch 2008-02-22 11:02:41 EST
Will be fixed in next setup package. /etc/profile.d/*.csh scripts will now be
executed from /etc/cshrc again if it isn't a login shell (otherwise they would
be called twice for login shells).

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.