Bug 381731 - Package Updater Crash
Summary: Package Updater Crash
Status: CLOSED DUPLICATE of bug 325901
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut   
(Show other bugs)
Version: 6
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-14 08:06 UTC by B
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-14 15:24:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description B 2007-11-14 08:06:48 UTC
Description of problem:
An unhandled exception has occurred.  This is most likely a bug.  Please save
the crash dump and file a detailed bug report against pirut at
https://bugzilla.redhat.com/bugzilla


Component: pirut
Summary: TB4dd9b21d HalCD.py:109:__getitem__:AttributeError: 'NoneType' object
has no attribute 'GetProperty'

Traceback (most recent call last):
  File "/usr/sbin/pup", line 614, in <module>
    main()
  File "/usr/sbin/pup", line 610, in main
    pup.run()
  File "/usr/sbin/pup", line 449, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 267, in doRefresh
    pbar = self.doRefreshRepos(destroy=False)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 302, in
doRefreshRepos
    self.reposSetup(pbar, thisrepo)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 268, in reposSetup
    self.doTsSetup()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 64, in doTsSetup
    return self._getTs()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 78, in _getTs
    self._tsInfo.setDatabases(self.rpmdb, self.pkgSack)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 522, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 381, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 239, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 142, in populate
    if self._check_db_version(repo, mydbtype):
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 199, in
_check_db_version
    if repo.repoXML.repoData.has_key(mdtype):
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 758, in <lambda>
    repoXML = property(fget=lambda self: self._getRepoXML(),
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 750, in _getRepoXML
    self._loadRepoXML(text=self)
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 733, in _loadRepoXML
    cache=self.http_caching == 'all')
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 563, in _getFile
    result = self.mediafunc(local = local, checkfunc = checkfunc, relative =
relative, text = text, copy_local = copy_local, url = url, mediaid =
self.mediaid, name = self.name, discnum = discnum, range = (start, end))
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 162, in
pirutCDHandler
    if not dev["volume.is_mounted"]:
  File "/usr/lib/python2.5/site-packages/pirut/HalCD.py", line 109, in __getitem__
    return self.volumedev.GetProperty(item)
AttributeError: 'NoneType' object has no attribute 'GetProperty'

Local variables in innermost frame:
item: volume.is_mounted
self: <pirut.HalCD.HALBlockDevice instance at 0x130fcb0>
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jeremy Katz 2007-11-14 15:24:03 UTC

*** This bug has been marked as a duplicate of 325901 ***


Note You need to log in before you can comment on or make changes to this bug.