Bug 38191 - sun java sdk incompatible with textutils
Summary: sun java sdk incompatible with textutils
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: textutils (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-28 10:15 UTC by Tim Grant
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-28 10:15:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tim Grant 2001-04-28 10:15:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)


The Sun Java sdk is incompatible with the version of textutils shipped in
rh7.1 due to cut being moved from /usr/bincut to /bin/cut.  This can be
fixed with "ln -s /bin/cut /usr/bin/cut" however the jvm will still not
work (reason unknown).  The compiler does now work however.

Reproducible: Always
Steps to Reproduce:
1.java <class file>
2.
3.
	

Actual Results:  starts three java threads and hangs

Expected Results:  successful program execution

Comment 1 Bernhard Rosenkraenzer 2001-04-30 16:52:15 UTC
Since they refuse to release the source code, there's nothing whatsoever we 
can do to fix their bugs. For cut, they should search $PATH - neither FHS nor 
LSB guarantee you'll find a version of cut in /usr/bin. I've added a symlink 
in textutils though, since some other apps are stupid enough to hardcode 
/usr/bin/cut, as well.

The segmentation fault is releated to their (again stupid and not standards 
compliant) insistence on the stack being fixed-size and 2 MB, neither of which 
is the case in the i686 build of glibc. Check the release notes for more 
details and the workaround for terribly broken applications like jdk.



Note You need to log in before you can comment on or make changes to this bug.